overdue-scratch

Author Topic: Hang on reading SystemVersion.plist  (Read 22134 times)

0 Members and 1 Guest are viewing this topic.

academy

  • Entrant
  • Posts: 1
Hang on reading SystemVersion.plist
« on: December 18, 2009, 08:45:04 PM »
After booting Snow Leopard a few times, it suddenly stops working for no apparent reason.  After clicking Snow Leopard in Chameleon RC4, I see one line detailing the loading of SystemVersion.plist and a chameleon in the background and then it just hangs.  If I ignore caches, I instead get a blank screen with a chameleon.

The only solution I have found is repartitioning.  Erasing the chameleon partition doesn't work.  Repairing the permissions doesn't work.  Reinstalling Snow Leopard without formatting doesn't work.

Any ideas?  I'd really appreciate the help.

Adam

CharredPC

  • Observer
  • Posts: 12
Re: Hang on reading SystemVersion.plist
« Reply #1 on: December 19, 2009, 12:32:34 AM »
This is interesting. I ran into the same error with RC4 whenever I tried to use deep sleep (hibernate). It seems that as long as a new sleep file is never created (set sleep mode to 0, never try hibernating) I'm able to use RC4. Otherwise, it sticks like you describe until the boot file is replaced with RC3 (RC4 can be put back after a successful RC3 OSX boot). Is it possible that your issue is caused by the same thing?

Sam3oun

  • Entrant
  • Posts: 2
Hang on reading SystemVersion.plist
« Reply #2 on: December 22, 2009, 04:51:44 PM »
Yeah im having the same thing ... it was working normally b4 updating to rc4 .... installed rc4 successfully ... even booted a few times with rc4 with no problems, all of a sudden it hangs on "Loading HSF+ /../../../SystemVersion.plist" (using verbose mode) deleted my whole system did it all over again (SL 10.6.2)
everything went well, thought id give RC4 a second chance ... installed rc4 successfully ... and booted a few times well ... next day what do i see ??? the SAME LINE!!!! "loading HSF+ [somehing/something/.../.../.../SystemVersion.Plist]" AGAIN??? WHY????   

CharredPC

  • Observer
  • Posts: 12
Re: Hang on reading SystemVersion.plist
« Reply #3 on: December 22, 2009, 09:08:41 PM »
Sam3oun:

It is annoying, but you can get around it by typing "Wake=n" at boot, and never ever use hibernate again  ::)

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: Hang on reading SystemVersion.plist
« Reply #4 on: December 22, 2009, 09:26:06 PM »
Can this somehow be related to the new PlatformUUID that RC4 sets?

Maybe the hibernatefile or something in SystemVersion.plist is looking for the old PlatformUUID that you had before installing RC4 and then getting stuck because it doesn't match.

I can't check for this myself because I don't use hibernation.

Maybe it's as simple as booting in single user mode and deleting the hibernatefile first?
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

Sam3oun

  • Entrant
  • Posts: 2
Re: Hang on reading SystemVersion.plist
« Reply #5 on: December 23, 2009, 12:56:38 AM »
Sam3oun:

It is annoying, but you can get around it by typing "Wake=n" at boot, and never ever use hibernate again  ::)

tried that didn't work, plus i dont use hibernaion ... anyway i just copied the "boot" file from RC3 and its working gr8 ... guess no RC4 for me

GFX

  • Entrant
  • Posts: 9
Re: Hang on reading SystemVersion.plist
« Reply #6 on: January 26, 2010, 11:34:21 AM »
I experiened the same thing for three times. Even after the updates it happened.
The only thing not to live the same problem is to install every updates manually and before it stars 'Repair Permission'. Otherwise it gets stucked.

Apex

  • Observer
  • Posts: 23
Re: Hang on reading SystemVersion.plist
« Reply #7 on: February 01, 2010, 10:40:41 AM »
I was very happy when i saw that RC4 should fix wake-from-disk. But i am having exactly the same issue. The System hangs with the "Loading HFS+ File .... SystemVersion.plist" line when the boot device is selected.
All i can say is, wake-from-disk worked ONE time when i had two harddrives in my system. But i had to remove one harddrive and it stopped working. Maybe someone gets a idea here...

Zane

  • Member
  • Posts: 81
Re: Hang on reading SystemVersion.plist
« Reply #8 on: June 17, 2010, 10:51:18 PM »
Any updates on this?
http://bit.ly/osx86log Lenovo Y550P OSx86 Log
http://bit.ly/envyosx64log HP Envy 15 1150nr OSx64 log

CharredPC

  • Observer
  • Posts: 12
Re: Hang on reading SystemVersion.plist
« Reply #9 on: June 28, 2010, 04:37:46 AM »
I've been forced to roll back to RC3 in order to reliably boot my computer. Otherwise, I have a very good chance of getting stuck at the SystemVersion.plist line. This is somewhat annoying, since RC4 fixed cpu detection for me... but I'd rather have a usable machine and deal with a "2.6 GHz Unknown" cpu. It would be wonderful if someone could fix this.

(Triple booting OSX 10.5.8, OSX 10.6.2, and Win7- use 10.5.8 daily. Problem only occurs on my Leopard install, and often occurs after booting into Win7. Sometimes is able to be fixed by booting to SL, then back to Leopard (???). Otherwise, any RC3 boot cd gets me back in, and can boot itself thereafter.)

zef

  • Administrator
  • Posts: 265
Re: Hang on reading SystemVersion.plist
« Reply #10 on: June 28, 2010, 09:24:05 PM »
I've been forced to roll back to RC3 in order to reliably boot my computer. Otherwise, I have a very good chance of getting stuck at the SystemVersion.plist line.

Do you still stuck at SystemVersion.plist even if you boot with trunk/r151+ builds?
ASUS P8Z68-V PRO/GEN3 | i5-2500k | 16GB RAM | GTX560 | Keyboard | Mouse | Devilsound DAC

Zane

  • Member
  • Posts: 81
Re: Hang on reading SystemVersion.plist
« Reply #11 on: August 07, 2010, 05:34:03 PM »
@zef do you mean i need to compile the latest builds myself? I am not too sure how to compile, but i think i got one of the compiled rekusor build.

This one i think. http://tonymacx86.blogspot.com/2010/02/chameleon-rc5-prerelease-installer.html

and i still get the issue.
http://bit.ly/osx86log Lenovo Y550P OSx86 Log
http://bit.ly/envyosx64log HP Envy 15 1150nr OSx64 log

zef

  • Administrator
  • Posts: 265
Re: Hang on reading SystemVersion.plist
« Reply #12 on: August 07, 2010, 06:49:37 PM »
This one i think. http://tonymacx86.blogspot.com/2010/02/chameleon-rc5-prerelease-installer.html

and i still get the issue.

There were fixes committed regarding this issue since February, try the recent trunk revisions here: http://goo.gl/iLu2 - thanks Azimutz! :)

« Last Edit: August 07, 2010, 07:16:19 PM by zef »
ASUS P8Z68-V PRO/GEN3 | i5-2500k | 16GB RAM | GTX560 | Keyboard | Mouse | Devilsound DAC

Zane

  • Member
  • Posts: 81
Re: Hang on reading SystemVersion.plist
« Reply #13 on: August 07, 2010, 08:04:59 PM »
This one i think. http://tonymacx86.blogspot.com/2010/02/chameleon-rc5-prerelease-installer.html

and i still get the issue.

There were fixes committed regarding this issue since February, try the recent trunk revisions here: http://goo.gl/iLu2 - thanks Azimutz! :)

Alright, will test it out. Thanks!

EDIT: Testing it. So far so good i guess, but we'll see. ^_^ Great that it fixed my CPU detection information. I think it fixed my Webcam too. Somehow. ^_^
« Last Edit: August 07, 2010, 08:24:38 PM by Zane »
http://bit.ly/osx86log Lenovo Y550P OSx86 Log
http://bit.ly/envyosx64log HP Envy 15 1150nr OSx64 log

Azimutz

  • VoodooLabs
  • Posts: 420
  • Paranoid Android
Re: Hang on reading SystemVersion.plist
« Reply #14 on: August 08, 2010, 06:19:40 PM »
Zef :)

Zane, do a full install if you're using old stuff.. check my signature.
 System & Patches: http://goo.gl/i961
 Chameleon:
- trunk builds: http://goo.gl/9G1Hq
- pref pane: http://goo.gl/OL2UT