overdue-scratch

Author Topic: Backporting the Meklort patches for auto patching mach_kernel's CPUID panic etc.  (Read 54934 times)

0 Members and 1 Guest are viewing this topic.

meklort

  • VoodooLabs
  • Posts: 65
Those three issues should fixed now.

I do have an issue with the memory module on my dell mini 10v, but not on my mini 1012 (or my desktop), so I'll try to track that down (and sync it with the changes in trunk).

As far as the gui goes, I can't seam to reproduce the bug. On three of my machines the gui start up perfectly. If you wan't I can send you the compile version from my branch so that you can test if that works or doesn't work.
« Last Edit: September 23, 2010, 07:38:28 AM by meklort »
return c ? c : !c;

Azimutz

  • VoodooLabs
  • Posts: 420
  • Paranoid Android
Hi... sorry for the delay; been feeling sick...
Yes, at rev 541, the PciRoot UID is working fine and platform UUID is also read fine from DMI table.

GUI related...; besides the GUI not loading, i always need to boot in verbose mode; without -v i don't get "boot" screen and after login i can only see a small portion of the screen, something like 1/2 of the width and 1/3 of the eight, starting from the upper left corner of the screen. I'm guessing this can be related to the Resolution module so, i tried removing it but then i get
Quote
Unable to locate symbol _getResolution.
and an instant reboot.

Yep, maybe it's better to check against a build of your own; shouldn't make any diff since i'm compiling directly from a checkout of your branch but, one never knows. Meanwhile, will review things again on my side.
 System & Patches: http://goo.gl/i961
 Chameleon:
- trunk builds: http://goo.gl/9G1Hq
- pref pane: http://goo.gl/OL2UT

meklort

  • VoodooLabs
  • Posts: 65
Things should work without verbose mode now, you won't have the apple logo though, at least not yet.

I'll upload a working version (for me) tonight have you try it out.
return c ? c : !c;

Azimutz

  • VoodooLabs
  • Posts: 420
  • Paranoid Android
Gave a try to rev 548, gives me an instant reboot some were after loading drivers... need to add some pauses to get a fix on were it's really coming from. After lunch... be back later.

Update: ok, i can overcome the instant reboot with UseMemDetect=n.
But, i see that some stuff is not ready so, i'm going to wait on your input.
« Last Edit: September 25, 2010, 03:18:00 AM by Azimutz »
 System & Patches: http://goo.gl/i961
 Chameleon:
- trunk builds: http://goo.gl/9G1Hq
- pref pane: http://goo.gl/OL2UT

meklort

  • VoodooLabs
  • Posts: 65
Well, the good news is I was able to reproduce some of the issues you had with an asus machine. I'll try to fix the bugs soon.
return c ? c : !c;

Azimutz

  • VoodooLabs
  • Posts: 420
  • Paranoid Android
OK, nice. I'm keeping an eye on your progress... no problemo.
« Last Edit: September 25, 2010, 01:15:58 PM by Azimutz »
 System & Patches: http://goo.gl/i961
 Chameleon:
- trunk builds: http://goo.gl/9G1Hq
- pref pane: http://goo.gl/OL2UT

meklort

  • VoodooLabs
  • Posts: 65
Well, I've fixed at least some of the issues, let me  know if it works any better now.
return c ? c : !c;

Azimutz

  • VoodooLabs
  • Posts: 420
  • Paranoid Android
Status at rev 552:
- GUI still doesn't show signs of life; module loads but, that's it.
  Still needs Resolution module loaded or gives instant reboot.
- USBFix module loads, but the fixes don't work, whatever key i use.
  I do get a warning while building the module but don't think that's the problem...
  One thing is curious though; i still didn't had any usb problem while booting with your branch ???

The rest seems fine; the gray boot screen is showing without -v and no problems after login.

« Last Edit: October 06, 2010, 02:22:33 PM by Azimutz »
 System & Patches: http://goo.gl/i961
 Chameleon:
- trunk builds: http://goo.gl/9G1Hq
- pref pane: http://goo.gl/OL2UT

valv

  • VoodooLabs
  • Posts: 72
    • The AnVAL Forum (fr)
@Meklort,
Congrats for the heavily good job you're at. I'd like to give you some feedback after having mixed your code with mine:
- Neither GUI nor Memory modules are working.
- Still some warnings on compiling GraphicsEnabler & USBFix:
Quote
GraphicsEnabler.c: In function ‘GraphicsEnabler_start’:
GraphicsEnabler.c:24: warning: passing argument 2 of ‘register_hook_callback’ from incompatible pointer type
USBFix.c: In function ‘USBFix_start’:
USBFix.c:29: warning: passing argument 2 of ‘register_hook_callback’ from incompatible pointer type
- Other irrelevant warnings:
Quote
Memory.c: In function ‘Memory_hook’:
Memory.c:57: warning: implicit declaration of function ‘scan_memory’
Networking.c: In function ‘set_wifi_airport’:
Networking.c:132: warning: unused variable ‘temp2’
- Most important, make optionrom gives this:
Quote
/usr/bin/ranlib: file: sym/i386/libsaio.a(nbp.o) has no symbols
/usr/bin/ranlib: file: sym/i386/libsaio.a(ntfs.o) has no symbols
/usr/bin/ranlib: file: sym/i386/libsaio.a(ext2fs.o) has no symbols
ranlib: file: sym/i386/libsaio.a(nbp.o) has no symbols
ranlib: file: sym/i386/libsaio.a(ntfs.o) has no symbols
ranlib: file: sym/i386/libsaio.a(ext2fs.o) has no symbols
/usr/bin/ld_classic: Undefined symbols:
_drawColorRectangle
collect2: ld returned 1 exit status
make[2]: *** [boot] Error 1
make[1]: *** [optionrom] Error 2
make: *** [optionrom] Error 2
- make debug is no joy neither, maybe related to utils.

meklort

  • VoodooLabs
  • Posts: 65
Well, fixed the warnings and the err with make optionrom (do note that the modules won't work load correctly yet with make optionrom, it's not done).

Let me know if the gui and memory modules load in my branch, if it doesn't there's no reason trying to trace down a bug in your branch when it's a bug within mine.
return c ? c : !c;

valv

  • VoodooLabs
  • Posts: 72
    • The AnVAL Forum (fr)
that's funny: I was about to post how I've managed to get rid of the minor warnings (GraphicsEnabler etc..), just to find u got it already.

valv

  • VoodooLabs
  • Posts: 72
    • The AnVAL Forum (fr)
Neither GUI nor Memory are working yet. sorry!
Endless reboots when one of those 2 is into the modules folder.

Azimutz

  • VoodooLabs
  • Posts: 420
  • Paranoid Android
Status at rev 570:
we have progress :)
   
been testing this most part of the day:
- HPET.dylib still didn't gave any signs of life. I don't need it but, it doesn't hurt to check it.
- USBFix.dylib, shows some signs of life but never works properly and when it shows, never gets printed to bdmesg;
  booting with -f it's the best way to see some activity. I mentioned on my last post that i wasn't having usb problems
  with your branch, that's not true anymore, the usual problems are back.
- GUI.dylib it's finally working and it doesn't instant reboot without Resolution.dylib :)
  I also had to remove Resolution.dylib, or the resolution wouldn't let me see the prompt.
  Besides this, the only glitch is a reload of the of the guy, right after loading the kernel (check attached log).
 
The rest seems to work properly, excluding NBI & KextPatcher, which i didn't tested.

p.s.: GUI=No gives just a black screen, no Text Mode; removing the module works fine.
     
« Last Edit: October 27, 2010, 09:10:07 PM by Azimutz »
 System & Patches: http://goo.gl/i961
 Chameleon:
- trunk builds: http://goo.gl/9G1Hq
- pref pane: http://goo.gl/OL2UT

Eps

  • Entrant
  • Posts: 7
Great!! Build 577 can boot into system at least in verbose mode on my HP mini 2140.
Thanks your effort!!

Azimutz

  • VoodooLabs
  • Posts: 420
  • Paranoid Android
Hi Meklort, hope you're fine :)

I noticed one of these days that the KernelPatcher is not working with 10.6 kernel; so, after i saw your commit (rev 597) i gave a run through the kernels; tested all 10.6 kernels (even 10.6.5) except for 10.6.2...
The only one that failed was still the 10.6 one; no problem with the others both 32/64 bit; only tested 32 bit on 10.6.5 (64 bit only after source release). I tested this with the kernel patcher on "my branch", after updating with rev 597 stuff.

About your branch, last check i did was with rev 576... basically the same problems i mentioned about rev 570.
Will give a try at the latest stuff as soon as i can...

See ya...
 System & Patches: http://goo.gl/i961
 Chameleon:
- trunk builds: http://goo.gl/9G1Hq
- pref pane: http://goo.gl/OL2UT