Author Topic: ALC889A pin configuration  (Read 2627 times)

0 Members and 1 Guest are viewing this topic.

potuz

  • Entrant
  • Posts: 2
ALC889A pin configuration
« on: June 03, 2010, 08:24:21 PM »
Hello list, this might be in the opposite direction of what is usually asked here, but I have been having problems with this for over a year now. I own a macbook Air 2,1 with the Realtek ALC889A soundcard. I wiped out Mac OS X from it and installed only Linux (I have no interest on a flame war, just care about the codec in this post). The thing is that with the current Linux driver (ALSA) we can't make the mic work. Since you guys have developed tons of Kexts for this chip and the datasheet is not available I was wandering if you could put in me in the right direction.

As of now I could only figure out that using

0x18 as main speaker
0x14 as HP and switch
0x19 as HP when it is connected

I get audio in the main speaker and headphones appropriately. But I do not know which verb one should use to get the mic working.

Any help will be greatly appreciated.

Cheers,

R.

m3s_4ev3r

  • Entrant
  • Posts: 3
Re: ALC889A pin configuration
« Reply #1 on: June 08, 2010, 07:36:08 PM »
Hey, can you please give me some baseline advices on how can I identify my pins, I need to recompile the source of voodoohda to make it work on a VT1708B chipset, I found a partially workign dirver, but that's it, so, how can I get my pins, and where inside voodoohda source do I modifiy it, noob question, I know, but we all have to start somewhere.

THANKS!

potuz

  • Entrant
  • Posts: 2
Re: ALC889A pin configuration
« Reply #2 on: June 08, 2010, 07:49:00 PM »
Hi, I would add a new topic since that question is completely different than the original one. Anyhow I wouldn't know how to probe the codec in mac os X. On Linux there are several tools like hdaverb and such.

R.

m3s_4ev3r

  • Entrant
  • Posts: 3
Re: ALC889A pin configuration
« Reply #3 on: June 08, 2010, 07:50:59 PM »
I meant in Windows, everything works there, in Ubuntu with the latest ALSA digital out still not working.....