VoodooPS2Controller > General Discussion

Can't get VoodooPS2 to play nice with a Synaptics trackpad


I've installed/reinstalled voodoops2controller several times at the advice of users on #snowleopard, but for whatever reason, my laptop's trackpad (a Synaptics) can never move the cursor. I've tried going into the VoodooPS2 pref pane, but it complains about not being able to find AppleSynapticsPS2Trackpad (I think) and I see no options that look like they'll help me get the trackpad working. I have deleted a bunch of the original PS2 support related kexts from S/L/E, again at the direction of users on #snowleopard, but this just left me with a really bizarre stuck key problem for a while. Also, (I don't think this has anything to do with Voodoo, but maybe someone here knows why it happens) USB mice and keyboards don't seem to work -- unless I use an official apple keyboard and plug a USB mouse (any USB mouse) in through that. I'd really appreciate any help you can give me. I'm really excited about using OSX, but I just can't do anything with it until it works better with my hardware...

yes, me too

Sorry for the noob question, but where did you get the source code?

I have attached my kexts and a scroll reverser app that work for my Synaptics PS/2 trackpad and laptop keyboard on SL 10.6.8 (not sure about L/ML).  I tried this Voodoo as well and it did not work.  Try it out, good luck!


[0] Message Index

Go to full version