Author Topic: Couple of post-installation DSDT issues  (Read 3711 times)

0 Members and 1 Guest are viewing this topic.

x0b

  • Entrant
  • Posts: 0
Couple of post-installation DSDT issues
« on: July 27, 2010, 12:08:17 PM »
Hi,

I hope someone can help me with some post-installation issues I'm having:

I installed SL using Kakewalk 2.2 with the Gigabyte EP45-DS3L settings, which worked ok in enough that it installed and I could boot to the OS. This method uses Chameleon boot loader RC4. 2 things which didn't work were sleep which I'm not fussed about and my Texas Instruments PCI firewire card (which worked fine in Leopard out of the box).

I decided to try and get this all working by editing my boards own dsdt and getting rid of the one supplied by Kakewalk. I got my dsdt using the Windows 7 version of Dsdt Editor and fixed 3 errors and 1 warning so it compiled properly. I have attached this file DSDT_errors_fixed.aml in the zip. The untouched one is DSDT_untouched.aml in the zip.

My installation will not boot with my dsdt like this, I do not get a KP but after the grey Apple screen I just get a blank screen, and in verbose mode I do not get any errors that I can see, but again it goes to the blank screen. At first I thought it was the graphics but these are enabled in the com.apple.Boot.plist file (also attached in the zip). The graphics work fine using the dsdt supplied with Kakewalk, so I guess there is some difference that is stopping me from booting fully.

I began to patch my dsdt using Dsdt Editor, but even after applying all the patches relevant to me (DSDT_mine_patched.aml in zip), I still cannot get to the desktop, so I am at a bit of a loss as to where to go from here. Does anyone have an idea about why I am getting this blank screen? Is there another debugging method I could use to find out?

As I need to get the firewire working to use my sound card, I decided to patch the Kakewalk dsdt that boots to the desktop ok (DSDT_kakewalk_ep45_with_patches.aml), and I got sleep working (waking from sleep with mouse causes system to freeze after a couple of minutes, not sure whether it has locked up or USB stops working yet), as well as speedstep as far as I can tell, but firewire still doesn't. I've been doing a lot of reading on firewire issues and it seems people are having success by adding the device in their dsdt. I have already tried moving the firewire card to other pci slots and also removing AppleHPET.kext (which caused KP), but neither worked.

I get the following error when booting in verbose mode FireWire runtime power conservation disabled. (2)
And console.log shows SPFWR ERROR: FireWire bus may be unstable. Other FireWire devices may be present.
And system profiler shows unable to list firewire devices.

I haven't tried any firewire dsdt fixes yet, as I would like to get my own dsdt working properly first, but some guidance on doing this would be very much appreciated. I have attached my ioreg and lspci -nn outputs in the zip as well, and also my smbios.plist file just for good measure!
Retail OSX 10.6.4 - Intel Q6600 @ 2.4 - Gigabyte P35-S3G - 4GB Corsair 800Mhz RAM - XFX Alpha-Dog 8800GT w/ Arctic Cooling Accelero AC-S1 rev 2 - Presonus Firebox Audio Interface - Lacie Firewire 400 PCI Card by Sismo with Texas Instruments Chipset - Broadcom 43xx Wireless Card - Logitech Wave Desktop Keyboard and Mouse

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: Couple of post-installation DSDT issues
« Reply #1 on: July 27, 2010, 05:00:54 PM »
Not related to the Chameleon bootloader - welcome to the Black Hole!

This is not a general Hackintosh support forum.

That said, the best place to find help with Gigabyte EP45 series boards is here:
http://www.efixusers.com/index.php
Also take a look at this:
http://cartri.net/blog/mac-bios-status-table
And this is the motherload:
http://www.insanelymac.com/forum/index.php?showtopic=192518
Hope that pushes you in the right direction. Good luck.
« Last Edit: July 27, 2010, 09:01:40 PM by Gringo Vermelho »
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

Terc

  • Forum Moderator
  • Posts: 129
Re: Couple of post-installation DSDT issues
« Reply #2 on: August 04, 2010, 07:27:39 AM »
Nice links Gringo.  I know I'd be giving you a thanks if I was looking for the help x0b was.

x0b

  • Entrant
  • Posts: 0
Re: Couple of post-installation DSDT issues
« Reply #3 on: August 04, 2010, 11:13:27 AM »
Thanks for the links, will have a good read.  :)
Retail OSX 10.6.4 - Intel Q6600 @ 2.4 - Gigabyte P35-S3G - 4GB Corsair 800Mhz RAM - XFX Alpha-Dog 8800GT w/ Arctic Cooling Accelero AC-S1 rev 2 - Presonus Firebox Audio Interface - Lacie Firewire 400 PCI Card by Sismo with Texas Instruments Chipset - Broadcom 43xx Wireless Card - Logitech Wave Desktop Keyboard and Mouse

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: Couple of post-installation DSDT issues
« Reply #4 on: August 05, 2010, 07:20:30 AM »
 :P
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131