Author Topic: Installed WIN7 and chameleon wont boot, help!  (Read 1711 times)

0 Members and 1 Guest are viewing this topic.

Ruximeh

  • Entrant
  • Posts: 2
Installed WIN7 and chameleon wont boot, help!
« on: July 25, 2010, 08:53:01 PM »
Hi all, I am a rookie on this, and I need some help. (English is not my first language, sorry for any mistakes)

I have three PCs with mac installed and chameleon running, and I wanted to install Windows 7 on two of these macs, so I partitioned the HD and installed win7.
Windows 7 started to run normally on both PCs, but now I cant boot on Mac because chameleon wont run when I start the computers...

I'm writing from the third PC, where I already tried putting the other machines HD's (they work here).

How can I make Chameleon work again on those computers without formatting and losing stuff (except for windows, it can be removed)

I already tried removing the windows partition, but it did nothing but making the PC stay with a black screen and a white dot blinking...

also, I cant get to bott on the Leopard one like im booting with the snow leopard hd

Oh, One PC has Snow Leopard and the other Leopard

EDIT: I managed to put chameleon on the snow leopard through this guide:http://tonymacx86.blogspot.com/2009/11/how-to-install-chameleon-manually-from.html , but now when I put the HD in the machine, it says Missing Operating System!

« Last Edit: July 25, 2010, 11:12:01 PM by Ruximeh »

Terc

  • Forum Moderator
  • Posts: 129
Re: Installed WIN7 and chameleon wont boot, help!
« Reply #1 on: July 25, 2010, 09:26:13 PM »
Windows installs its own bootloader, so when you installed Windows, you removed Chameleon (or at least marked a different partition as the bootable partition).

Ruximeh

  • Entrant
  • Posts: 2
Re: Installed WIN7 and chameleon wont boot, help!
« Reply #2 on: July 25, 2010, 09:57:42 PM »
yeah, but i cant install chameleon on the mac again(running the snow leopard on the third pc)... I need help on doing that

jbreher

  • Observer
  • Posts: 18
Re: Installed WIN7 and chameleon wont boot, help!
« Reply #3 on: August 09, 2010, 09:15:04 PM »
Installing Win 7 overwrites sector 0, and also (apparently) the first sector of whatever partition is marked active. In order to accomplish an OS X / Win 7 dual boot system, the formula I used was:

(see http://forum.voodooprojects.org/index.php/topic,1490.0.html)

In Disk Utility, Partition disk as GUID, 2 partitions (plus the EFI partition it won't tell you about), format first partition as HFS+ Journalled.
Install OS X on this newly formatted partition.
Install Chameleon as normal.
Verify proper OS X operation.

Using Disk Utility, format second partition as FAT  (unsure if this is necessary)
Boot Win 7 install disk, but do not install yet!
Get to cmd window, use diskpart to make the FAT32 partition active, format this partition as NTFS

Install Win 7 to NTFS partition. Your system will now boot only windows.

Reinstall Chameleon -- but use boot0hfs in the MBR rather than the standard boot0.
Gigabyte GA-EP45-UD3P / Intel Celeron Dual Core E1400 2.0 GHz / 800 MHz FSB / ASUS EN8400GS Silent/HTP/512M PCIe x16
4GiB (2x2) G.Skill DDR2-10666, PC2-8500, 2048MB x 2, CL-5-5-5-15 2.0~2.1V DRAM / 750 GB Seagate Barracuda 7200.11 SATA HDD ST3750330AS / hp dvd1170i SATA DL DVD
EFI (empty) / iPC 10.5.6 / Win 7 pro x64
... oh yeah, and an i7 17" MBP

jbreher

  • Observer
  • Posts: 18
Re: Installed WIN7 and chameleon wont boot, help!
« Reply #4 on: August 09, 2010, 09:26:36 PM »
Hmm. I seem to have given you some useless information. Looks like you need to get over the hump of being able to boot any Chameleon, period.

Use the third machine to create a bootable Chameleon USB stick.

On the broken machines, set BIOS to boot from USB HDD (or similar, depending on your BIOS). The Chameleon on the USB stick can be coaxed to boot the OS X image on your HDD. Once booted into OS X, you can install boot0hfs to the MBR, which may solve your problem*. Set the BIOS back to boot off the HDD and test.

If still unbootable, change BIOS back to USB, and reboot OS X using Chameleon on the USB stick as a bootloader. Install boot1h to the OS X partition, and that should have you up and running*.

* While others may know, I do not yet know whether or not the installer for Win 7 screws up boot1h on the active partition.
Gigabyte GA-EP45-UD3P / Intel Celeron Dual Core E1400 2.0 GHz / 800 MHz FSB / ASUS EN8400GS Silent/HTP/512M PCIe x16
4GiB (2x2) G.Skill DDR2-10666, PC2-8500, 2048MB x 2, CL-5-5-5-15 2.0~2.1V DRAM / 750 GB Seagate Barracuda 7200.11 SATA HDD ST3750330AS / hp dvd1170i SATA DL DVD
EFI (empty) / iPC 10.5.6 / Win 7 pro x64
... oh yeah, and an i7 17" MBP