2

Author Topic: [Solved] multiple graphic cards issue : GTX 460 and 8800 GTX  (Read 3111 times)

0 Members and 1 Guest are viewing this topic.

hallelujah

  • Entrant
  • Posts: 2
[Solved] multiple graphic cards issue : GTX 460 and 8800 GTX
« on: September 27, 2010, 03:15:43 AM »
Hello,
I ran into a weird issue with my graphic cards, below is my config :

GA-X58A-UDR3 rev 2.0
Asus EN8800GTX
MSI 460 GTX

I have two different cards on my Hackintosh : a new 460 GTX and a 8800 GTX from my old config.
I know that 460 GTX is not supported yet (new chip G104) (will it ?)
The 8800 GTX works out of the box with GraphicsEnabler=yes without the 460 GTX plugged in

gfxutil -f display
DevicePath = PciRoot(0x1)/Pci(0x3,0x0)/Pci(0x0,0x0)

But when I try to plug both cards Snow leopard freezes
Is there a workaround ? (I found one : unplug the 460 GTX when booting SL but it is very painful   :'()

Thanks for any suggestion

EDIT : Is there a way to blacklist a hardware component or a simple way with patching chameleon source code ?
« Last Edit: September 27, 2010, 07:19:38 AM by hallelujah »

hallelujah

  • Entrant
  • Posts: 2
Re: multiple graphic cards issue : GTX 460 and 8800 GTX
« Reply #1 on: September 27, 2010, 07:18:59 AM »
I solved my issue ;D here is how i get it work :

- Disconnect 460 GTX
- Install chameleon 2.0 RC5
- Edit /Extra/com.apple.Boot.plist
- Dump String injection devices from chameleon prefpane and copy the result to in.plist
- use ./gfxutil -i xml -o hex ./in.plist  ./out.hex
- paste content of out.hex in device-properties string value

Both cards works but I have to disable  GraphicsEnabler
460 GTX -> VGA 1024x768
8800 GTX -> All