overdue-scratch

Author Topic: SMcputype (and others) not working with SMBIOSdefaults=n on RC5  (Read 27999 times)

0 Members and 1 Guest are viewing this topic.

NetBoot

  • Observer
  • Posts: 24
Re: SMcputype (and others) not working with SMBIOSdefaults=n on RC5
« Reply #45 on: January 04, 2011, 04:56:29 AM »
Yeah, I know about the smbios info I'm using.  I haven't finshed tweaking it.  But I made the changes that you recommended.  Thanks for the help on that.

Question about HyperThreading.  I tried enabling HyperThreading in the PC BIOS in the past and the system would lock up.

I just tried it again and now the system is up and running.  But, I don't see any changes to the System Profile. The number of Processors and cores are still 1

Should this change?

Thanks for being so patient with me.

Net....

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: SMcputype (and others) not working with SMBIOSdefaults=n on RC5
« Reply #46 on: January 04, 2011, 05:23:16 AM »
Having hyperthreading enabled doesn't change the fact that you have 1 CPU with 1 Core, so that information should stay that way.

Try running Activity Monitor and take a look there, IIRC it *should* show two "CPU Usage" windows. Not sure, the P4 hack runs Windows 7 all the time, it's been a while since I've booted up OS X on it.

Try installing the processor prefpane, it comes with Apple Developer Tools and is buried somewhere in the /Developer folder. Once you find it, just double click on it to install it. It'll probably say 'unknown' as well but IIRC it should show two threads. Sorry but I rarely boot up OS X on the P4 anymore and I don't remember all the juicy details.

Could you add wait=y to your com.apple.Boot.plist and post a photo of the information shown on bootup here?
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

NetBoot

  • Observer
  • Posts: 24
Re: SMcputype (and others) not working with SMBIOSdefaults=n on RC5
« Reply #47 on: January 04, 2011, 06:02:44 AM »
I have to disable HyperThreading.

I'm losing my USB High Speed Bus.

Net....

NetBoot

  • Observer
  • Posts: 24
Re: SMcputype (and others) not working with SMBIOSdefaults=n on RC5
« Reply #48 on: January 04, 2011, 10:29:27 AM »
When I use Wait=yes all I get is press an key to continue

Net....

Kabyl

  • VoodooLabs
  • Posts: 158
Re: SMcputype (and others) not working with SMBIOSdefaults=n on RC5
« Reply #49 on: January 04, 2011, 10:55:14 AM »
The booter doesn't support Base64.

Azimutz

  • VoodooLabs
  • Posts: 420
  • Paranoid Android
Re: SMcputype (and others) not working with SMBIOSdefaults=n on RC5
« Reply #50 on: January 04, 2011, 08:53:22 PM »
When I use Wait=yes all I get is press an key to continue
You need to use -v (verbose) argument too; but you can also use "bdmesg" to get the "booter-log" ;) ask if you don't know what i'm talking about.
And i think you need to slow down a bit, read and give it more time;
i'm reading for 3 years and most of the time, i still feel like a damn noob!

Ok, using Kabyl's branch or Chameleon (trunk), remove the smbios.plist you're using and check what cpu, Mac model, etc... the booter gives you by default! The booter has default values, you only need to change them via plist if they are incorrect or missing. Most probably you will only need the serial; you should get iMac1,8 and Core Solo cpu.
And 257 is the code for Core 2 Solo, which apple never used, some crazy dude found some where and i was wondering if it would work on a Pentium 4...
You would know all this stuff if you've read the topic properly ::)

By the way, does your P 4 has em64t (Intel 64)?



Gringo, you need to emend
Code: [Select]
<key>SMcputype</key>
<string>0102</string>
on post #42; it needs to be a "decimal" value :)
« Last Edit: January 04, 2011, 08:55:52 PM by Azimutz »
 System & Patches: http://goo.gl/i961
 Chameleon:
- trunk builds: http://goo.gl/9G1Hq
- pref pane: http://goo.gl/OL2UT

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: SMcputype (and others) not working with SMBIOSdefaults=n on RC5
« Reply #51 on: January 04, 2011, 09:04:48 PM »
Azi, I don't understand?  :o
To my eyes, that's exactly what it says in post #42.
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

Azimutz

  • VoodooLabs
  • Posts: 420
  • Paranoid Android
Re: SMcputype (and others) not working with SMBIOSdefaults=n on RC5
« Reply #52 on: January 04, 2011, 10:34:22 PM »
Well, in this case/example it needs to be
Code: [Select]
<key>SMcputype</key>
<string>513</string>
which is the decimal of 0x0201 (or 0x201), which ends up on IOreg byte flipped, 0102.

0x0201 - Core Solo/Duo (dec 513)
0x0301 - Core 2 Duo (dec 769)
0x0501 - Dual-Core/Quad-Core Xeon (dec 1281)
0x0601 - Core i5 (dec 1537)
0x0701 - Core i7 (dec 1793)
0x0901 - Core i3 (dec 2305)
and the bastard
0x0101 - Core 2 Solo (dec 257)

You mention correctly next...
Quote
As you can see even the author tells you to use 1281, 257 etc...
The hex values above are from Chameleon code; don't ask me why it uses hex instead of dec :P
« Last Edit: January 04, 2011, 10:40:18 PM by Azimutz »
 System & Patches: http://goo.gl/i961
 Chameleon:
- trunk builds: http://goo.gl/9G1Hq
- pref pane: http://goo.gl/OL2UT

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: SMcputype (and others) not working with SMBIOSdefaults=n on RC5
« Reply #53 on: January 05, 2011, 01:44:00 AM »
woah, "identification through obfuscation" :-)

Thanks again.
« Last Edit: January 05, 2011, 01:47:09 AM by Gringo Vermelho »
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

konsti

  • Member
  • Posts: 32
Re: SMcputype (and others) not working with SMBIOSdefaults=n on RC5
« Reply #54 on: January 26, 2011, 09:23:20 PM »
Guys, just to inform you that the latest R699 Chameleon that I am using (thanks to Azimutz's signature-binaries) does not fix the problem, compared to R693 from Kabyl's branch that works flawlessly. This, again, referring to the SMBIOSdefaults option, to properly parse/inject SMcputype variable. Just for the record 8)
Thanks again.

konsti

  • Member
  • Posts: 32
Re: SMcputype (and others) not working with SMBIOSdefaults=n on RC5
« Reply #55 on: January 25, 2012, 12:45:43 AM »
Hello to all and happy new year. Has this been fixed in the recent versions of Chameleon RC5? Can anyone confirm, please? Thanks in advance.

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: SMcputype (and others) not working with SMBIOSdefaults=n on RC5
« Reply #56 on: January 25, 2012, 02:31:08 AM »
The RC (Release Candidate) 5 dev cycle was frozen and the last revision became Chameleon 2.0 Final.

Chameleon is presently at version 2.1 r18xx.

I don't know if your issue has been fixed.

Upgrade to Chameleon 2.1, get rid of the smbiosdefaults key/string in (was: com.apple.Boot.plist) org.chameleon.Boot.plist and place only model identifier and other Mac DMI data in smbios.plist. No memory stuff, no CPU stuff, Chameleon should auto detect all of that.

Something we didn't discuss here is that it's possible your smbios.plist is corrupt and Chameleon can't read all the values in it.
If you zip and attach your smbios.plist here, I'll make a clean one for you with Apple dev tools plist editor.
« Last Edit: January 25, 2012, 02:52:30 AM by Gringo Vermelho »
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131