Chameleon > Bug Reports

SMcputype (and others) not working with SMBIOSdefaults=n on RC5

<< < (2/12) > >>

Yep Gringo.. i was going to mention that later... Chameleon does override the cpu-type set by the kernel, if any; i can confirm that, since i'm using the legacy kernel atm without any changes. So, as SMBIOSdefaults=n is currently disabling cpu-type setting, if we use it, the value set by the kernel will be used, which can be confusing if we forget the fact ::)

Anyway, the booter should be setting Core Solo for any cpu with just one core! If that is not working, then we have a bug.
Can't test that stuff on my Pentium D; you'll need to feedback :)

Gringo, about the keyboard all i can think of is "legacy usb"; i need it enabled on Bios for my wireless keyboard to be detected.

I'll be back... still checking some stuff...

Dear Azimutz, thanks for taking the time to reply and sorry you have to deal with us "newbies" regarding the deeper use of Chameleon  :lol:

Since there's apparently no clear documentation, I was under the impression that:

Using SMBIOSdefaults=Yes doesn't make the system need smbios.plist file, as everything is detected by Chameleon (CPU, RAM speed, RAM types/serial, CPU Bus speeds etc.). Perhaps the system (or kernel, as you say) sets the most appropriate SMproduct according to what is pushed by Chameleon.

Using SMBIOSdefaults=No make the system badly need smbios.plist file in order to have all the parts defined (again, (CPU, CPU Bus speeds, RAM speed, RAM types/serial etc. AND product-type i.e. MacPro3,1 or MacBook2,1 etc.) as Chameleon doesn't bother detecting anything.

On my ICH7 Core2Quad mobo, if I set SMBIOSdefaults=Yes the CPU is recognised and the RAM modules as well. Actually, they are reported as 802MHz rather than 800MHz.

With SMBIOSdefaults=No I get no CPU type ("unknown") so I don't know if Chameleon parses/pushes the info from smbios.plist.

I apologize if I got it all wrong; I was never able to find a good post to explain what the heck SMBIOSdefaults does, at the end of the day  8)

Gringo Vermelho:
I installed 2.0 RC5 r647 on the P4 (10.5.8, qoopz Voodoo derivative 9.8.0) and the CPU is now correctly set as Core Solo. Someone must have fixed that somewhere during the RC5 dev cycle. :) 

I am using a MacPro1,1 smbios.plist, no SMBIOSdefaults flag in

The memory detection does not fully work with the i865PE/ICH5 though, type and speed are correct but partnumbers, manufacturer and serials are not set.

8086:2570 82865G/PE/P DRAM Controller/Host-Hub Interface ... if anybody wants to bother with something this old.

I haven't tried an SMcputype override, but at least I can confirm that the automatic override works now.

So dear Gringo, to get a better understanding; you installed this RC5 build r347 and used a custom-made smbios.plist file, and the CPU is properly displayed as Core Solo? Without SMBIOSdefaults=Yes or SMBIOSdefaults=No?

Please try the very latest builds of Chameleon; get them from Azimutz's signature. In early builds, this thing as I described above works; with latest build, the SMcputype is not pushed to the system (taken from smbios.plist) when SMBIOSdefaults=No!

Cheers and good night.

Gringo Vermelho:
Sorry about the typo, I meant r647. I've edited my post. I'll upgrade to r653 but don't think it'll make any difference.
/EDIT - indeed, it still works.
I compile Chameleon from svn trunk myself, find my builds in my install guide here:,649.0.html

I use a MacPro1,1 smbios.plist with only model data in it (no SMcputype) and no SMBIOSDefaults flag set in /Extra/c.a.B.p.

At this point I can't say if it's Chameleon or the Voodoo Kernel that's responsible for the correct CPU override, but it works.

And sorry about the threadjack Konsti, my issue was only slightly related to yours and turned out to be a non-issue!


[0] Message Index

[#] Next page

[*] Previous page

Go to full version