overdue-scratch

Author Topic: [ERROR] ntfs_fixup: magic doesn't match  (Read 12006 times)

0 Members and 1 Guest are viewing this topic.

synapse

  • Entrant
  • Posts: 1
[ERROR] ntfs_fixup: magic doesn't match
« on: April 15, 2009, 08:02:21 PM »
Hi everyone...since 2 or 3 day i noticed this message flickering beneath the gui on the left side of the screen when i move through the drives:

Code: [Select]
ntfs_fixup: magic doesn`t match: 0000000 != 454c4946
and when i choose the HDD to boot from i can see some actions loading (flickering at the bottom of the screen) before the apple logo and the loading starts.

I have an ntel DG35EC - CPU: IntelĀ® Core 2 Quad Q6700 - Memory: 4GB DDR2 800 Kingston - VGA: nVididia GeForce 8800GT 512MB DDR3 - Retail OS X 10.5.6 (on GUID) and another HDD with Vista ???

Mod Edit: Two separate unanswered topics for the same problem have been merged together to help consolidate this issue.
« Last Edit: January 22, 2011, 10:23:25 AM by Blackosx »

jangawhat

  • Entrant
  • Posts: 1
Re: [ERROR] ntfs_fixup: magic doesn't match
« Reply #1 on: December 18, 2010, 06:51:10 PM »
hello

computer boots fine, able to chose between osx and windows 7 with chameleon and both work but before chameleon gui it has this ntfs_fixup message that appears for around 2-3 seconds

chameleon rc4 i wasn't getting this message, i upgraded to rc5 because i had hibernate sleep issues with Windows 7 and rc4 didn't have boot0hfs to set windows 7 as active partition (fixed now with rc5)

using rc5 Dec 18 2010 Trunk 668 currently (i've tried other versions of rc5 and it persists) and tried rc4 again to make sure it wasn't something else, doesn't show up with rc4



/dev/disk0
#: TYPE NAME SIZE IDENTIFIER
0: FDisk_partition_scheme *500.1 GB disk0
1: Windows_NTFS Windows 32.2 GB disk0s1
2: Apple_HFS OSX 31.8 GB disk0s2
3: Windows_NTFS Games 62.9 GB disk0s5
4: Windows_NTFS Media 367.0 GB disk0s6
5: DOS_FAT_32 BACKUP 6.2 GB disk0s7

Slice

  • VoodooLabs
  • Posts: 52
Re: [ERROR] ntfs_fixup: magic doesn't match
« Reply #2 on: January 21, 2011, 08:12:41 PM »
A month no any attempt to answer.

Blackosx

  • Forum Moderator
  • Posts: 1150
Re: [ERROR] ntfs_fixup: magic doesn't match
« Reply #3 on: January 21, 2011, 10:37:01 PM »
Hi Slice

It's good that you are now frequenting this forum as your skills can help with questions like this. These type of issues need a developers eye to look over the source code to help determine the reasons why it happens. I mean I can search the source for 'ntfs_fixup: magic doesn't match' and find it's in /i386/libsaio/ntfs.c but without studying the code (with my non-developer knowledge) to find out why it happens I can't give the OP an explanation.

And unfortunately in this forum, you will see a few questions / posts unanswered due to the lack of dev knowledge by the likes of myself who frequent here. This is not ideal, but the other devs such as Zef and Kabyl can't be here all the time to assist.

Maybe in the forthcoming restructure a better system can be attained for these type of issues? as currently bugs are posted here in the forum or posted as issues on the repo which leaves the chance for posts to be missed.

@Gringo - yes there is another thread about this but it's also unanswered.
http://forum.voodooprojects.org/index.php?topic=167.0

Edit: I've merged both topics in to this one.
« Last Edit: January 22, 2011, 10:25:49 AM by Blackosx »
10.10.5 / 10.11 GM1 | Asus Maximum IV Gene-Z | i7-2600 3.40GHz | 4GB | Radeon 5770 1GB

Slice

  • VoodooLabs
  • Posts: 52
Re: [ERROR] ntfs_fixup: magic doesn't match
« Reply #4 on: January 22, 2011, 12:47:32 PM »
IIRC we already have another thread here about this. I don't remember if the issue was resolved though.
Is it possible to make this info public here?
Why this forum exists if most important info about the projects can be found at other places or just in private conversations?

Blackosx

  • Forum Moderator
  • Posts: 1150
Re: [ERROR] ntfs_fixup: magic doesn't match
« Reply #5 on: January 22, 2011, 10:20:21 PM »
Is it possible to make this info public here?
Hi Slice
I've already merged the topic Gringo was talking about in to this thread. That post is now post #1 because it was the oldest and there are no extra posts because that post was also unanswered.

10.10.5 / 10.11 GM1 | Asus Maximum IV Gene-Z | i7-2600 3.40GHz | 4GB | Radeon 5770 1GB

pharaon

  • Entrant
  • Posts: 3
Re: [ERROR] ntfs_fixup: magic doesn't match
« Reply #6 on: February 13, 2011, 03:07:03 PM »
The same problem. Where I can find a solution?

And... when "Errors encountered while starting up the computer. Pausing 5 seconds" will be fixed?

Maybe it is usefull to edit like this:

    if (gErrors) {
        msglog("Errors encountered while starting up the computer.\n");
       // printf("Pausing %d seconds...\n", kBootErrorTimeout);
       // sleep(kBootErrorTimeout);
    }

pbryanw

  • Entrant
  • Posts: 1
Re: [ERROR] ntfs_fixup: magic doesn't match
« Reply #7 on: March 16, 2011, 12:35:30 AM »
Just some observations made on my machine (so don't know if they can be replicated):

Removing the keys and values for "Default Partition" & "Hide Partition" (I hide four partitions) from my com.apple.Boot.plist makes the ntfs_fixup messages disappear. Unfortunately, this means I boot into OS X, when I want my default OS to be Windows 7.

Removing these keys, however, gets rid of the "Errors encountered" message when booting into OS X. Restoring the "Default Partition" key means that I get no ntfs_fixup messages when booting into Windows 7, but the "Errors encountered" message comes back for OS X.

I'd be interested if anyone can replicate these findings, or can find out if these are symptoms of a bigger problem, or it's down to a problem with using these keys in RC5 in com.apple.Boot.plist?

(My system is setup to boot into Chameleon (Quiet Boot) which is on my OS X HD, which then boots into Windows 7. Windows 7 is on a separate HD, as is Ubuntu Linux. I see the ntfs_fixup message for perhaps a second or two with my usual com.apple.Boot.plist settings.)
« Last Edit: March 16, 2011, 12:40:27 AM by pbryanw »

Breathless

  • Entrant
  • Posts: 1
Re: [ERROR] ntfs_fixup: magic doesn't match
« Reply #8 on: September 15, 2011, 10:33:36 PM »
Thanks for that tid bit about removing Default and Hidden partitions. If anyone has figured this out further, please let us know

unimatrix725

  • Observer
  • Posts: 10
Re: [ERROR] ntfs_fixup: magic doesn't match
« Reply #9 on: September 16, 2011, 05:58:25 PM »
Hi Slice

It's good that you are now frequenting this forum as your skills can help with questions like this. These type of issues need a developers eye to look over the source code to help determine the reasons why it happens. I mean I can search the source for 'ntfs_fixup: magic doesn't match' and find it's in /i386/libsaio/ntfs.c but without studying the code (with my non-developer knowledge) to find out why it happens I can't give the OP an explanation.

And unfortunately in this forum, you will see a few questions / posts unanswered due to the lack of dev knowledge by the likes of myself who frequent here. This is not ideal, but the other devs such as Zef and Kabyl can't be here all the time to assist.

Maybe in the forthcoming restructure a better system can be attained for these type of issues? as currently bugs are posted here in the forum or posted as issues on the repo which leaves the chance for posts to be missed.

@Gringo - yes there is another thread about this but it's also unanswered.
http://forum.voodooprojects.org/index.php?topic=167.0

Edit: I've merged both topics in to this one.

 I totally agree with you. I do look here frequently and sometimes find answers, and its good reading too. I think if possible to setup something like what the xda-developers have would be perfect for  this. Those unfamiliar, it is a development thread for the Sony X10 (and other android related) it is segregated a little. The devs have their own threads with open viewing and restrictions on posting there. Then they have the threads for everyone, not just devs who do peek in from time to time.

For those interested go here:
http://forum.xda-developers.com/forumdisplay.php?f=617

AuralArch

  • Observer
  • Posts: 12
Re: [ERROR] ntfs_fixup: magic doesn't match
« Reply #10 on: March 28, 2013, 01:43:25 PM »
This peculiar alert has been stalking me, getting increasingly more bothersome as it has come to fill the screen 1.5 times before displaying my menu.  I'm now beginning to suspect there's a correlation the number of HDDs (& partitions) I add to my system and how many times the error repeats on my screen.

I can't help but wonder- does everyone who uses the "Default Partition" & "Hide Partition" keys for NTFS drives (or who have NTFS drives in their build) get this error?  I'm leaning towards "No" because there seems to be very little activity or interest in this issue.  EDIT: Ooops- I guess I must rethink my conclusions-  I just noticed after posting how many views this thread has accumulated!
Or possibly far fewer people actually use these keys than I imagine.  Also I suppose that there are some who just don't notice or care about "mismatched magic"...  maybe many more than I presumed!
I have to remind myself that I have far more than the average # of HDDs attached to my system.  Using all 10 SATA ports on my mobo, plus 5 more on a port multiplier, as well as another 7 of 8 on a SAS add-in card- leaving space for 2 'guest' disks on my USB 3 ports- is not typical or normal!


It doesn't seem to cause or instigate any sort of major issue- it just adds about 8-10 seconds to my boot time.

I'm excited to see if the removal of those keys from my boot plist file will finally stop these pesky little messages that stall my system booting.

Still quite curious what is really behind these odd error alerts?...  Is it just a bug or a warning of something important? - that I should resolve!

Will repost here should I learn anything new/more about this messed up magic.   It would be great if someone here with a better understanding would share a bit of their insight!
« Last Edit: March 28, 2013, 02:00:42 PM by AuralArch »

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: [ERROR] ntfs_fixup: magic doesn't match
« Reply #11 on: March 28, 2013, 08:54:46 PM »
Try running chkdsk /F /R on all your NTFS partitions/drives.

Have you ever had any NTFS drives or partitions mounted as read/write in OS X?

If so try running ADS Spy or LADS and remove any leftover ADS you find:
http://www.merijn.nu/programs.php#adsspy
http://www.heysoft.de/en/software/lads.php

Read more here:
http://en.wikipedia.org/wiki/NTFS#Alternate_data_streams_.28ADS.29
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

iRipper

  • Observer
  • Posts: 26
Re: [ERROR] ntfs_fixup: magic doesn't match
« Reply #12 on: September 15, 2014, 08:57:39 PM »
Bump! I'm getting this problem out of the blue now  :o Everything worked perfectly, until I resized my Windows SSD partition to give more space to the C drive.