overdue-scratch

Author Topic: Help with SL Retail and Chameleon, blinking "_"  (Read 6629 times)

0 Members and 1 Guest are viewing this topic.

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: Help with SL Retail and Chameleon, blinking "_"
« Reply #15 on: May 13, 2011, 01:57:26 AM »
In theory (I'm about to test this myself, I haven't rebooted yet) it should be as simple as this:

Format the flash drive to FAT32 using Disk Utility, name it CHAM for example

In Terminal

diskutil list (to find out what disk number the flash drive has - the following assume rdisk3)

With i386 folder unzipped to desktop, type

cd ~/desktop/i386

sudo -s (enter your password)

./fdisk -f boot0 -u -y /dev/rdisk3

dd if=boot1f32 of=/dev/rdisk3s1

cp boot /Volumes/CHAM

exit

Now copy your Extra folder to it.

Bingo.

If you have "hide partition", "default partition" and/or "rename partition" set in com.apple.Boot.plist (you won't have those since you only have one hard drive) they need to be removed as the partition order will likely be completely different when booting from the flash drive.

I'm going to reboot now and see if I can boot from this thing.

/EDIT guess what, it didn't work. Hang on, I'll try formatting it in Windows.
« Last Edit: May 13, 2011, 02:08:33 AM by Gringo Vermelho »
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

iMithos

  • Observer
  • Posts: 15
Re: Help with SL Retail and Chameleon, blinking "_"
« Reply #16 on: May 13, 2011, 02:16:19 AM »
It gives you the same error than me?
« Last Edit: May 13, 2011, 02:30:55 AM by Gringo Vermelho »

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: Help with SL Retail and Chameleon, blinking "_"
« Reply #17 on: May 13, 2011, 02:38:01 AM »
Oh well formatting in Windows gave the same result. What's more, the flash drive becomes unreadable after trying to boot from it!

I don't get the same error as you, for me it's worse, I see boot0: error and then nothing else happens.

This should work, I think we are missing something but I don't know what.

For some reason I cannot use the new fdisk that ships with the Chameleon source, I get "permission denied" whenever I try to run it. Mine bombs out at boot0 because I'm using an older fdisk binary I guess.

/EDIT - after setting the flash drive partition active with fdisk I see the same error message as you.

I'm sure you will be able to boot if you can figure out a way to install Chameleon on FAT32 on your flash drive. Perhaps you could even initialize the EFI partition on your HDD to FAT32 and boot from that. But at this point I have no idea how this is supposed to work.

Hopefully someone else will see this thread and suggest something. In the meantime I'll hit google and see what I can find.

Try the password thing in your BIOS with Chameleon installed to the EFI partition on your HDD (see previous page).

Another thing; can I ask you to please don't quote my posts in their entirety when replying? As you may have noticed, I have edited all your previous posts and removed or trimmed the quotes. There is no reason to full-quote when you reply is directly below the post you are replying to, in the end the thread will be full of quotes with repeating garbage text that you have to scroll past and that is bad for readability.
« Last Edit: May 13, 2011, 02:57:48 AM by Gringo Vermelho »
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: Help with SL Retail and Chameleon, blinking "_"
« Reply #18 on: May 13, 2011, 03:04:06 AM »
I forgot about this, I'm going to try it: http://forum.voodooprojects.org/index.php?topic=1427.0

That post also explains why the drive becomes unreadable.
« Last Edit: May 13, 2011, 03:06:17 AM by Gringo Vermelho »
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

iMithos

  • Observer
  • Posts: 15
Re: Help with SL Retail and Chameleon, blinking "_"
« Reply #19 on: May 13, 2011, 03:12:16 AM »
I'll try it too :)

iMithos

  • Observer
  • Posts: 15
Re: Help with SL Retail and Chameleon, blinking "_"
« Reply #20 on: May 13, 2011, 03:30:46 AM »
The thing of the passwords don't worked for me
I'm going to test the corona's tutorial

EDIT: I still can't load chameleon after the coruna's tutorial T___T
« Last Edit: May 13, 2011, 03:56:56 AM by iMithos »

Blackosx

  • Forum Moderator
  • Posts: 1150
Re: Help with SL Retail and Chameleon, blinking "_"
« Reply #21 on: May 13, 2011, 10:43:44 AM »
I'm not sure if this is relevant as I haven't properly read the posts here, but I remember installing Chameleon to a FAT formatted EFI system partition using boot1f32. Maybe the steps can help here?
http://forum.voodooprojects.org/index.php/topic,1671.msg8677.html#msg8677
10.10.5 / 10.11 GM1 | Asus Maximum IV Gene-Z | i7-2600 3.40GHz | 4GB | Radeon 5770 1GB

iMithos

  • Observer
  • Posts: 15
Re: Help with SL Retail and Chameleon, blinking "_"
« Reply #22 on: May 13, 2011, 03:50:25 PM »
I formatted the "EFI" partition as fat32 and instaled chameleon in it, but I can start chameleon only when I have the WIndows 7 Install disc on the DVD reader and I ignore the message "Press any key to boot from cd..."
So, if I do that, chameleon starts
But if I try to start Mac OS X it crashes
:S

...

I'll give it as impossible to install&lauch chameleon in this laptop and forget all this

Thanks to all for helping me :)
« Last Edit: May 13, 2011, 04:06:13 PM by iMithos »

Blackosx

  • Forum Moderator
  • Posts: 1150
Re: Help with SL Retail and Chameleon, blinking "_"
« Reply #23 on: May 13, 2011, 04:50:27 PM »
I formatted the "EFI" partition as fat32 and instaled chameleon in it
...../snip/....
chameleon starts
So in a round-about way, Chameleon does actually load and run now?

but I can start chameleon only when I have the WIndows 7 Install disc on the DVD reader and I ignore the message "Press any key to boot from cd..."
This is strange and doesn't make any sense as you have the HDD set in BIOS as the 1st boot priority.
So what happens when you boot without the Windows 7 DVD in the drive? Can you disable the DVD drive in BIOS?

But if I try to start Mac OS X it crashes
Booting OS X brings a different set of problems and for that I suggest searching and reading a forum dedicated to running OS X on a PC. Try this link for a starting point. This forum is just dedicated to Chameleon.

I'll give it as impossible to install&lauch chameleon in this laptop and forget all this
If I've interpreted your post correctly then I think you have successfully installed and launched Chameleon

Thanks to all for helping me :)
YW :)
10.10.5 / 10.11 GM1 | Asus Maximum IV Gene-Z | i7-2600 3.40GHz | 4GB | Radeon 5770 1GB

iMithos

  • Observer
  • Posts: 15
Re: Help with SL Retail and Chameleon, blinking "_"
« Reply #24 on: May 13, 2011, 04:56:29 PM »
Quote
So in a round-about way, Chameleon does actually load and run now?
Yes

Quote
This is strange and doesn't make any sense as you have the HDD set in BIOS as the 1st boot priority.
So what happens when you boot without the Windows 7 DVD in the drive? Can you disable the DVD drive in BIOS?
You can see the boot priority in the first page of this topic
Simply: If I try to start from the hard drive without any boot cd, My laptop don't starts chameleon
If I put any boot cd and ignore the "Prss any key..." message, i can start chameleon

Quote
Booting OS X brings a different set of problems and for that I suggest searching and reading a forum dedicated to running OS X on a PC. Try this link for a starting point. This forum is just dedicated to Chameleon.
I know it, I have all the kexts for this laptop and all the .plist etc etc...


Quote
If I've interpreted your post correctly then I think you have successfully installed and launched Chameleon
Yes, but if I always need an Windows Boot CD to launch it... Hit my head with a Shotgun xD

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: Help with SL Retail and Chameleon, blinking "_"
« Reply #25 on: May 13, 2011, 05:11:17 PM »
Maybe the BIOS has a problem with reading HFS or GPT bootsector or MBR whatever it is it needs to read in order to boot...I don't understand these things very well  :)

It could boot into DOS on a flash drive - therefore I'm 99% sure it will work if you can FAT32 the EFI partition and install Chameleon there.

But we can't figure out how to get Chameleon working on a FAT32 formatted flash drive so...you will run into the same issues with the hard drive.

I would keep trying to get FAT32 working on the flash drive, and then once you succeed, use the same method on your hard drive.
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

iMithos

  • Observer
  • Posts: 15
Re: Help with SL Retail and Chameleon, blinking "_"
« Reply #26 on: May 13, 2011, 05:18:07 PM »
I would keep trying to get FAT32 working on the flash drive, and then once you succeed, use the same method on your hard drive.

If you finally get working it... Please, put here as you did