Chameleon > DevTalk

ATI/AMD GraphicsEnabler support (legacy, modules & missing devices)!

<< < (35/39) > >>

Hi, Azimutz,

Can I ask you a basic question?

When I type "./gfxutil -f display" in terminal, it displays as follows.


Then, what is the correct PciRootUID value? 0 or 3?

Interestingly, whatever I choose 0 or 1 or 3 in "PciRootUID=X" at the boot option, it boots normally.

No one describes exactly what "PciRootUID" means. (I searched through google extensively, but I did not find.)

What does the "PciRootUID" mean?

I believe UID =

PCIRootUID is probably the choosing of which "slot" your graphic card is. For example, if i have slots 0, 1 and 2 and if Chameleon is unable to find or boot correctly then you would have to manually specify PCIRootUID=0,1 or 2.

Thats what i think it does anyway.

The other question, i shall let Azi reply you.

Greetings Azimuts,

So I'm sort of in a testing phase with Lion, I updated to 10.7.1 quickly so I don't know if it was that update that started causing this, but every now and then the computer boots with a black screen. This is after the first grey screen, when the screen turns black then the drivers kick in I assume, and another gray screen comes on before the desktop appears. So in these cases, the display stays black, backlight is on. I believe others have had the same issue with similar cards, one apparently fixed it just by setting native res in the boot.plist, which I already do. System is booted, just no image during the black screen. One workaround is to sleep the system then wake. The image comes back then.

Should I be trying different framebuffers?

I am running an HD5750 with device ID 68BE added to the ATI5xxx kext and graphicsenabler=yes. Updated to Cham 2 RC5 Build 1174 to install Lion. Previously was on Kabyls build 700 for ATI support, enabled the exact same way, and that worked perfectly.

Hey Azimuts,

ive been trying to make my Graphics work for 3 days now and failed that far.

I have the same card as this one:

Last thing i was trying was downloading the "", added the AMDGraphicsEnabler.dylib to the modules folder and im also usind the "boot" file from the zip above.

if i start with GraphicsEnabler=Yes it will hang up with the line:
"Resetting IOCatalogue."

im not sure what to try next (find other kext, learn to compile my own...), may be you could give me a hint?

ps: a have Lion 10.7.1 if it matters

Hey guys.
I have ati 5470 1GB with 10.7.2 on my laptop is Asus K52JR
I created EDID file for resouliton . My display is Internal LVD Force EDID.
I'm using GraphicsEnabler
I have QE/CI and correct resouliton.
but it is 16 bit.
I have colour bandings. How Can I enable 32bit (24bit)


[0] Message Index

[#] Next page

[*] Previous page

Go to full version