Author Topic: Is support for AMD processors working in RC5?  (Read 1820 times)

0 Members and 1 Guest are viewing this topic.

angeldust_atlas

  • Entrant
  • Posts: 3
Is support for AMD processors working in RC5?
« on: July 06, 2011, 01:33:19 PM »
I have some doubts about support for AMD architecture or NVidia NForce chipset with RC5 versions of Chameleon.
The latest version which works to me is RC4 release 684. Any newer release from RC5 trunk is rebooting immediately after loading kext and kernel caches or it freezes in that moment.
I have installed 10.5.8 on system drive and for safety I have 10.6 install files expanded on backup drive with OSX86_ModUSB by Nawcom. On 10.6 volume I also have to replace file /boot with RC4 release to get it booting.
(My system: AMD Phenom X4-9550 CPU/nVidia Corporation MCP78S chipset/GeForce 9600 GT graphics)


Is there anybody who can confirm that AMD and NForce can run with RC5?
Or I'm stuck and when I will change graphics to newer card I will have to switch to Intel processor and MB as well?


Also I found one older post which shows the same symptoms here:
http://forum.voodooprojects.org/index.php/topic,1796.msg9370.html

I installed Mac OSX 10.6.3 used BootThink then upgraded to 10.6.5 and everything was fine until upgraded to 10.6.6.
I couldn't get NVEnabler work with my GeForce 6600 anymore so I tried to use Chameleon to replace BootThink. Also I can see RC5 is more and more powerful and charm.
I tried a few different version of Chameleon RC5 from build5xx to build699 with installer or without installer from kexts.com and got same result:

It loads all kexts from Extra/Extensions and System/Library/Extensions and then display TMSafetyNet.kext then an error pauses in boot for 5 seconds on the gray background. Then it briefly displays some system information such as graphic card memory etc and clear the screen. If it is 10.6.3 the screen becomes black background and load Mac OSX in safe mode.
If upgrade to 10.6.6 the system reboot without safe mode.

I feel the issue is not related to TMSafetyNet.kext because if I remove this kext it will have that error but different kext. I guess TMSafetyNet.kext is just the last kext it loaded. Also I tried using Chameleon loading the MacOSX Installation CD

I tried google and got most post are asking this question but no solution. Solution are "change different installation CD" or "try BootThink". Indeed reinstall BootThink solved the problem but it is not what I need.

Hardware info:
CPU: AMD althon 64 x2 4400+
MEM: 2.5G
Graphic: Geforce 6600

HDD: MBR - boot0 with Chameleon
disk0s1: System Reserved (Win7 BCD);
disk0s2: Win7 system;
disk0s3: boot (Active, with Chameleon);
disk0s4 Extension: Mac OSX System,  Ubuntu, swap, shared data etc.

The boot partition is a 120MB HFS format active drive installed with Chameleon.
under Boot parititon:
boot/Extra/Extensions
AppleNForceATA.kext
ElliottForceLegacyRTC.kext
EvOreboot.kext
fakesmc.kext
nForceIOATAFamily.kext
nForceLAN.kext
NullCPUPowerManagement.kext
SleepEnabler.kext (I tried remove this one but made no difference)

boot/Extra/themes/...

boot/Extra/com.apple.Boot.plist: (stripped xml header)
    <key>Default Partition</key>
    <string>hd(0,1)</string>
    <key>GraphicsEnabler</key>
    <string>Yes</string>
    <key>Kernel</key>
    <string>mach_kernel</string>
    <key>Kernel Flags</key>
    <string>arch=i386</string>
    <key>SystemId</key>
    <string>2F429ABE-BE6D-11DF-B946-A219E0D72085</string>
    <key>blacklist</key>
    <string>Yes</string>


To compare with, I have bootthink installed on System Reserved partition:

Same Kexts are copied under \Darwin\System\LibrarySL\Extensions
In com.apple.Boot.plist only has:
    <key>Kernel Flags</key>
    <string>-x32</string>


mach_kernel for AMD is copied to MacOS system drive and boot drive but it only loads the kernel from the system drive.


Can you see anything wrong? or give me any suggestion to find out the root cause?

Thanks