2

Author Topic: Add new nVidia ID for GeForce 405  (Read 5499 times)

0 Members and 1 Guest are viewing this topic.

DoZie

  • Entrant
  • Posts: 7
Add new nVidia ID for GeForce 405
« on: September 09, 2011, 11:43:15 PM »
Please add: 0x10DE10C5, "GeForce 405"

GeForce 405 1024MB device id is 10C5, vendor id is 10DE

nvidia.c:

Code: [Select]
{ 0x10DE109A, "N12E-Q5" },
// 10A0 - 10AF
// 10B0 - 10BF
// 10C0 - 10CF // <-- add to this id 10c5
{ 0x10DE10C3, "GeForce 8400 GS" },
// 1200 -
{ 0x10DE1200, "GeForce GTX 560 Ti" },
« Last Edit: September 09, 2011, 11:48:23 PM by DoZie »

ErmaC

  • Resident
  • Posts: 134
Re: Add new nVidia ID for GeForce 405
« Reply #1 on: September 10, 2011, 02:14:26 PM »
I add this "info" to my branch.
Test if it works commit 1520

Fabio
P6T Deluxe v1 i7 940 Quadro Fx 5600
P6T SE i7 920 GeForce GT 240

DoZie

  • Entrant
  • Posts: 7
Re: Add new nVidia ID for GeForce 405
« Reply #2 on: September 10, 2011, 10:41:40 PM »
i was download your branch.
opened terminal, looked for downloaded folder and typed "make" and got this:


Code: [Select]
mac-pro-dozie:ErmaC (branch) DoZie$ pwd
/Users/DoZie/Desktop/ErmaC (branch)

mac-pro-dozie:ErmaC (branch) DoZie$ make
make: *** No rule to make target `%.c', needed by `/Users/DoZie/.Trash/ErmaC'.  Stop.

mac-pro-dozie:ErmaC (branch) DoZie$ make config
/bin/sh: -c: line 0: syntax error near unexpected token `('
make: *** [config] Error 2

mac-pro-dozie:ErmaC (branch) DoZie$ make embedtheme
make: *** No rule to make target `embedtheme'.  Stop.


what i doing wrong?
compiled in 10.7 with Xcode 4.2(4D177b)

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: Add new nVidia ID for GeForce 405
« Reply #3 on: September 10, 2011, 11:11:46 PM »
Compiled fine here. I opened the Xcode project file though.
Xcode 3.6.2, 10.6.8. See attachment.
« Last Edit: September 10, 2011, 11:14:06 PM by Gringo Vermelho »
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

DoZie

  • Entrant
  • Posts: 7
Re: Add new nVidia ID for GeForce 405
« Reply #4 on: September 10, 2011, 11:24:50 PM »
thx, i'll try tomorrow.  :)
« Last Edit: September 12, 2011, 05:20:48 AM by Gringo Vermelho »

DoZie

  • Entrant
  • Posts: 7
Re: Add new nVidia ID for GeForce 405
« Reply #5 on: September 10, 2011, 11:41:09 PM »
it works fine, card automatically detected as GeForce 405 in chameleon boot log, but with GraphicsEnabler it still doesn't work at full power, can't change resolution and qe/ci still doesn't work.
« Last Edit: September 10, 2011, 11:44:31 PM by DoZie »

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: Add new nVidia ID for GeForce 405
« Reply #6 on: September 11, 2011, 05:08:06 AM »
Yeah the drivers still need to "know"/support the card.

If you're running Snow Leopard you must install the Quadro 4000 drivers from nvidia, the drivers that ship with 10.6.8 has no support for Fermi architecture cards.
« Last Edit: September 11, 2011, 05:13:46 AM by Gringo Vermelho »
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

DoZie

  • Entrant
  • Posts: 7
Re: Add new nVidia ID for GeForce 405
« Reply #7 on: September 11, 2011, 07:49:00 AM »
Yeah the drivers still need to "know"/support the card.

If you're running Snow Leopard you must install the Quadro 4000 drivers from nvidia, the drivers that ship with 10.6.8 has no support for Fermi architecture cards.
And what about 10.7, is there any solutions to run in lion?

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: Add new nVidia ID for GeForce 405
« Reply #8 on: September 12, 2011, 05:20:19 AM »
Please don't quote entire messages when replying directly below them...

Do you see GF100Hal.kext loading?
« Last Edit: September 12, 2011, 05:21:55 AM by Gringo Vermelho »
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

DoZie

  • Entrant
  • Posts: 7
Re: Add new nVidia ID for GeForce 405
« Reply #9 on: September 12, 2011, 07:39:21 AM »
Ok.
No, NVDANV50Hal.kext only loading at boot.
In safe mode it is booting normaly, but in normal boot i see, that driver is work, resolution set to high, but WindowServer crashed, because QE doesn't work.

DoZie

  • Entrant
  • Posts: 7
Re: Add new nVidia ID for GeForce 405
« Reply #10 on: September 12, 2011, 06:23:04 PM »
Under 10.6.6 Quadro 4000 drivers works perfectly, QE and resolution work. In 10.7 i've got crash at boot.

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: Add new nVidia ID for GeForce 405
« Reply #11 on: September 13, 2011, 01:58:38 AM »
NVDANV50Hal should not load for that card, you should have GF100Hal loading like you do on Snow Leopard.

Most likely your issue doesn't have anything to do with Chameleon and is better discussed on one of the general Hackintosh forums such as ProjectOSX or InsanelyMac.

10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131