overdue-scratch

Author Topic: Lets get the 6970m and Intel HD 3000 working  (Read 2376 times)

0 Members and 1 Guest are viewing this topic.

applehacker

  • Entrant
  • Posts: 6
Lets get the 6970m and Intel HD 3000 working
« on: October 17, 2011, 06:28:48 PM »
I have been working to get these working for a month now. I have custom compiled a chameleon bootloader, with my device ids in ATI.C. Chameleon bootloader recognizes the graphics card with "GraphicsEnabler=Yes", so my device IDs are correct. The framebuffer specified should also be correct. However, when OS X loads, I get a flash, and then only a black screen. this happens both with intel HD 3000 and ati radeon hd 6970m. What needs to be done to fix this? both device ids exist natively in stock kexts.

applehacker

  • Entrant
  • Posts: 6
Re: Lets get the 6970m and Intel HD 3000 working
« Reply #1 on: October 25, 2011, 10:57:44 PM »
come on, can anybody help me? I've fixed intel, but ati is still giving me issues. without any enablers, the 6970m is recognized by OS X full 1920x1080 resolution, but the colors are messed up and the display is fuzzy. it has to be something fixable! Please, help out, i'm really close to making this work!

ErmaC

  • Resident
  • Posts: 134
Re: Lets get the 6970m and Intel HD 3000 working
« Reply #2 on: October 26, 2011, 01:36:22 AM »
Try use my branch (Trunk)
http://forge.voodooprojects.org/p/chameleon/source/tree/HEAD/branches/ErmaC/Trunk
or add yourself this into ati.c (main trunk code)
I'm not a coder so I can't help you..
{ 0x6720,   0x04BA1028, CHIP_FAMILY_CAYMAN, "AMD Radeon HD 6970m", kElodea   }, // ErmaC no tested
good luck!
Fabio
P6T Deluxe v1 i7 940 Quadro Fx 5600
P6T SE i7 920 GeForce GT 240

applehacker

  • Entrant
  • Posts: 6
Re: Lets get the 6970m and Intel HD 3000 working
« Reply #3 on: October 26, 2011, 01:44:19 AM »
Try use my branch (Trunk)
http://forge.voodooprojects.org/p/chameleon/source/tree/HEAD/branches/ErmaC/Trunk
or add yourself this into ati.c (main trunk code)
I'm not a coder so I can't help you..
{ 0x6720,   0x04BA1028, CHIP_FAMILY_CAYMAN, "AMD Radeon HD 6970m", kElodea   }, // ErmaC no tested
good luck!
Fabio

6970M is not chip family cayman.... it is chip family barts ( it is a mobile barts chip)

I will give a try anyway, thanks!

ErmaC

  • Resident
  • Posts: 134
Re: Lets get the 6970m and Intel HD 3000 working
« Reply #4 on: October 26, 2011, 10:57:45 AM »
In my branch (ErmaC/Trunk)

I change for test
{ 0x6720,   0x04BA1028, CHIP_FAMILY_BARTS, "AMD Radeon HD 6970m", kElodea   },

As before.. It's all I can do

Good luck

Fabio
P6T Deluxe v1 i7 940 Quadro Fx 5600
P6T SE i7 920 GeForce GT 240