Chameleon > General Discussion

Linux not being seen by Chameleon. Error in setup? Auto scan on new Install?

(1/1)

gustave:
I have been trying to get this working for two days and have read all there is and tried many many install variants......
Chameleon is not seeing my Linux for a boot option. 

Setup:
128Gig SSD drive.  Mac install on first 60 gigs ( works fine ) and the rest is linux partitioned with GRUB on / of linux partition
2TB drive.  Not used for anything currently
160 SATA drive.  Linux install with grub on MBR

I have tried using ext4, ext3 and ext2 for the /boot ( 100 meg ) and /
I have tried installing on the SSD and the 160 sata.
I have tried re-installing Chameleon ( chimera from Multibeast ) over the Mac SSD partition again to try to recognize
I have tried both CentOS 6.2 and Fedora 16.

Does Chameleon automatically recognize new installs of other OS's?

Here is my partition table for all disks.  I would really appreciate assistance on what this could be.

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *120.0 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS OSX                     60.0 GB    disk0s2
   3: 21686148-6449-6E6F-744E-656564454649               1.0 MB     disk0s3
   4:                        EFI                         104.9 MB   disk0s4
   5:       Microsoft Basic Data                         50.3 GB    disk0s5
   6:                 Linux Swap                         9.4 GB     disk0s6
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *2.0 TB     disk1
   1:                        EFI                         209.7 MB   disk1s1
   2:                  Apple_HFS STORAGE                 2.0 TB     disk1s2
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *160.0 GB   disk2
   1: 21686148-6449-6E6F-744E-656564454649               1.0 MB     disk2s1
   2:                        EFI                         104.9 MB   disk2s2
   3:       Microsoft Basic Data                         21.0 GB    disk2s3
   4:                 Linux Swap                         1.1 GB     disk2s4

lenb:
I've got a similar problem.  HP 4530s (i5).  Booting from iBoot 3.3 I see OSX & linux, but from my OSX install I only see OSX.

Any ideas?

Thanks.

rosmaniac:
Resurrecting old thread.

I have made this work by changing the /boot filesystem's partition type to 0700 using gdisk (under either Linux or OS X), and making sure the Linux boot loader is installed to the /boot partition.  Here's what such a partition table looks like for a dual boot system here:

--- Code: ---[root@localhost ~]# gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.1

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 976773168 sectors, 465.8 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 976773134
Partitions will be aligned on 8-sector boundaries
Total free space is 525717 sectors (256.7 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1              40          409639   200.0 MiB   EF00  EFI System Partition
   2          409640       386210423   184.0 GiB   AF00  OSX
   3       386473984       402104319   7.5 GiB     8200  LinuxSwap
   4       402104320       484024319   39.1 GiB    0700  LinuxRoot
   5       484024320       861511679   180.0 GiB   0700  LinuxHome
   6       861511680       976510983   54.8 GiB    AF00  Interchange
[root@localhost ~]#

--- End code ---

In my case, I'm not using a /boot partition, the /boot is in the root filesystem on /dev/sda4 (using the Linux terminology).  GRUB is installed on /dev/sda4 (not in the MBR of /dev/sda, of course!).

Navigation

[0] Message Index

Go to full version