overdue-scratch

Author Topic: Blinking cursor at boot when 2T WD Time Machine drive is connected  (Read 8098 times)

0 Members and 1 Guest are viewing this topic.

sapele

  • Observer
  • Posts: 18
Re: Blinking cursor at boot when 2T WD Time Machine drive is connected
« Reply #15 on: February 10, 2012, 10:00:08 PM »
That was it.

OK the following text appears with or without the drive connected just after the line

Verifying DMI Pool
PDptpppGll+_

then if I hit enter I get stuck at the blinking cursor (drive connected) with no further text

If the drive is not connected i hit enter and I see something like boot/ flash for a split second below the text then the cursor blinks fox a second or two in the upper left and the chameleon GUI begins.


Blackosx

  • Forum Moderator
  • Posts: 1150
Re: Blinking cursor at boot when 2T WD Time Machine drive is connected
« Reply #16 on: February 11, 2012, 10:42:25 AM »
Well done for getting it to work :)

From what I can tell (based on dmazar's previously posted results), the verbose text shows that boot0 is working correctly.

So I guess the next port of call will be to try a debug version of the stage 1 hfs code; boot1h.
However, I am having trouble compiling a debug version due to some errors:
Code: [Select]
boot1h.s:994: error: TIMES value -67 is negative
boot1h.s:1452: error: TIMES value -64 is negative
I see this is mentioned in the source code of boot1h.s and I guess a fix/workaround is needed to enable a successful build.
I'm trying a couple of different things here though to be honest I'm guessing and it might need to be looked at by one of the devs.

So for now, I guess my help here has come to a stop. I'll return here if I ever find a solution, or maybe somebody else could chip in with some solutions for this? or a reason why your machine won't boot with your time machine drive connected.

Go ahead and replace boot0workDBG with the standard boot0md if you want. You do it using the same steps with the command line as you used for writing boot0workDBG, but just write boot0md instead.

Regards
blackosx
« Last Edit: February 11, 2012, 10:47:55 AM by Blackosx »
10.10.5 / 10.11 GM1 | Asus Maximum IV Gene-Z | i7-2600 3.40GHz | 4GB | Radeon 5770 1GB

sapele

  • Observer
  • Posts: 18
Re: Blinking cursor at boot when 2T WD Time Machine drive is connected
« Reply #17 on: February 11, 2012, 12:20:04 PM »
Thanks so much for all of the help!

I will try a series of unscientific maneuvers, such as changing the data ports on my system and reformatting the time machine drive.  I will report back if anything makes a difference.

dmazar

  • Member
  • Posts: 52
Re: Blinking cursor at boot when 2T WD Time Machine drive is connected
« Reply #18 on: February 11, 2012, 04:52:35 PM »
Hi guys.

Blackosx, unfortunately boot0* and boot1* can not be compiled with debug because debug code make them longer then it is allowed. Developers were probably loading and debugging them a bit differently then we are using it now.

Sapele, from reading what was posted so far, the only idea I got is that when you connect your 2T Time Machine disk computer use it as boot disk and tries to boot from it. But in this case, if you write boot0workDBG only to your 500 GB Chameleon disk and not to 2T disk you would not see debug output when booting with 2T disk connected.

Anyway, are you sure that you are still booting from 500G Chameleon disk even when you connect 2T disk? How are you connecting this disk and what "diskutil list" prints for it?

If I were you, I would try to see if stage 2 boot file (500G /Volumes/Chameleon/boot file) is being loaded with and without 2T disk.
If you have Chameleon on USB which you can use for booting, then you can delete or rename /Volumes/Chameleon/boot file and try to boot from 500G disk. You should get boot1: error with and without 2T disk.

Don't do it if you can not boot from this alternative USB method.

If you get this error with 2T disk connected, then we know boot0 and boot1h are working fine and problem is in stage 2 boot file.
If you do not get this error, then ... I do not know ... probably means that you are not booting from 500G drive.

Blackosx

  • Forum Moderator
  • Posts: 1150
Re: Blinking cursor at boot when 2T WD Time Machine drive is connected
« Reply #19 on: February 12, 2012, 10:26:14 AM »
Hey dmazar :)

Yes, boot1h grew to 1088 bytes after force compiling with debug enabled. I tried hacking out the code for case sensitive filesystems to see if I could make space for debug by I failed miserably.. So I stopped doing that.

@Sapele - it's worth trying what dmazar suggested. For ref, you can build yourself a bootable USB flash drive easily enough with the Chameleon package installer which you already have. Just remember to add your DSDT and Extensions to the /Extra folder to match how you currently have it on your hard drive. Test booting from it before removing boot from your hard drive. You can then keep the USB booter as a backup rescue device if you ever need one.
10.10.5 / 10.11 GM1 | Asus Maximum IV Gene-Z | i7-2600 3.40GHz | 4GB | Radeon 5770 1GB

dmazar

  • Member
  • Posts: 52
Re: Blinking cursor at boot when 2T WD Time Machine drive is connected
« Reply #20 on: February 12, 2012, 12:54:10 PM »
Blackosx, maybe he has Advanced Format 4K drive. Real 4K, not 4K with 512 emulation. I've read that big external drives in USB cases usually are pure 4K drives. Chameleon stage 2 boot scans all drives for bootable volumes - maybe it hangs there. Do you know if stage 2 boot supports scanning of 4K drives?

sapele

  • Observer
  • Posts: 18
Re: Blinking cursor at boot when 2T WD Time Machine drive is connected
« Reply #21 on: February 12, 2012, 01:29:29 PM »
Dmazar

Thanks for the suggestions.  I can verify that I get the boot 1 error with and without the drive connected.  That said I have made progress

I booted into OSX without the 2T time machine disk connected- plugged it in to one of the native data ports and it mounted the same as always (problem seemed to only happen at boot)  I then partitioned it in order to erase the disk (it GUID format)  then to my surprise I was able to reboot and GET PAST the blinking cursor problem!

OK I plan on setting the drive up for use with TimeMachine again.  I will let you know if the problem returns.

On another note I am not able to remove the debug version of boot.  I tried running the instructions with the following change, not sure that is what you had in mind Blackosx?  I am sure that you can tell that I am not very capable when it comes to working in terminal.  Sorry

sudo ./fdisk440 -f boot0md -u -y /dev/rdisk0

dmazar

  • Member
  • Posts: 52
Re: Blinking cursor at boot when 2T WD Time Machine drive is connected
« Reply #22 on: February 12, 2012, 06:37:34 PM »
Reformatting the drive would be the last thing I would do. Fortunately, you did it and it made some progress with it.  ;D

Your command for installing boot0md looks good. Just use diskutil list before, and make sure you are pointing to correct disk with /dev/rdiskX. And that boot0md is in your current folder - type "ls -al" before and check if it is listed.

sapele

  • Observer
  • Posts: 18
Re: Blinking cursor at boot when 2T WD Time Machine drive is connected
« Reply #23 on: February 12, 2012, 07:54:46 PM »
Thanks for the instructions, I will try it later.  More important things first.

The problem is resolved!  After the reformat and 735gigs of back up via TM I can successfully reboot the machine with the disk connected.  I wish that I understood why so that it could contribute to development, but that is way out of my limited understanding.

Thanks so much for all of the help
Sapele

dmazar

  • Member
  • Posts: 52
Re: Blinking cursor at boot when 2T WD Time Machine drive is connected
« Reply #24 on: February 12, 2012, 08:24:07 PM »
Great.

By the way, you can use volume name(s) in "Default Partition" and "Hide Partition" in boot config instead of hd(x,y).

sapele

  • Observer
  • Posts: 18
Re: Blinking cursor at boot when 2T WD Time Machine drive is connected
« Reply #25 on: February 12, 2012, 10:00:35 PM »
Very cool I did not know that about the partition name. 

Am I supposed to remove the debug version of bootmd?  If I am I am not sure how to do that.

When I am done how would I check to make sure that I have executed all of the commands correctly?

thanks

dmazar

  • Member
  • Posts: 52
Re: Blinking cursor at boot when 2T WD Time Machine drive is connected
« Reply #26 on: February 13, 2012, 09:40:20 AM »
Debug version is the one that prints PDpt... letters and waits for key press during boot. If you still have it - you should remove it by installing regular version.

It's the same procedure as Blackosx explained before:
http://forum.voodooprojects.org/index.php/topic,2321.msg11558.html#msg11558
http://forum.voodooprojects.org/index.php/topic,2321.msg11534.html#msg11534
except that instead of boot0workDBG use boot0md.

If you can boot without those  PDpt... letters, then you have done it.

sapele

  • Observer
  • Posts: 18
Re: Blinking cursor at boot when 2T WD Time Machine drive is connected
« Reply #27 on: March 06, 2012, 01:55:11 PM »
I am so sorry to bother you all again.  I just can't get rid of the boo0workmd.  I followed the instructions to the letter and i still boot with the dppp string.

Could somebody provide instructions to remove the boot0workmd perhaps the boot0md is there too and will take over?  Grasping at straws here and I do not know where to look or how to delete anything.

thanks


Blackosx

  • Forum Moderator
  • Posts: 1150
Re: Blinking cursor at boot when 2T WD Time Machine drive is connected
« Reply #28 on: March 06, 2012, 02:50:33 PM »
Welcome back sapele.

Here's what you need to do.
1 - Make sure you have a tested and working backup boot device such as a bootable USB flash drive. Every user should have at least one of these to hand to allow you to rescue the system incase you do something wrong.
2 - Identify the HDD you're booing from that has the boot0workDBG code in the MBR. You should know which drive has the code as you put it there previously. Make sure you know which disk you're going to update - don't guess!
3 - From within OS X, use diskutil list from the Terminal (as you've done before) to find that drive's IDENTIFIER. for example, disk1
4 - Download the latest Chameleon from the buildbot - as of now it's Chameleon-2.1svn-r1869.tgz. Put it on your desktop and double click the archive to extract the files.
5 - Back in Terminal, enter the following command but replace the X at the end with the disk number from step 3.
Code: [Select]
sudo ~/Desktop/Chameleon-2.1svn-r1869/usr/bin/fdisk440 -f ~/Desktop/Chameleon-2.1svn-r1869/usr/standalone/i386/boot0md -u -y /dev/rdiskXThe above command will write the boot0md file to the first 440 bytes of the boot sector of disk1, over writing the boot0workDBG code.

Any questions, just ask :)
« Last Edit: March 06, 2012, 02:56:05 PM by Blackosx »
10.10.5 / 10.11 GM1 | Asus Maximum IV Gene-Z | i7-2600 3.40GHz | 4GB | Radeon 5770 1GB