Chameleon > General Discussion

Removed one hard disk, now I got message "Still waiting for root device".

(1/1)

zorro23:
I had 3 hard disks in hackintosh with 10.7.4 installed and Chameleon bootloader. It was working OK since 10.7.
One of hard disk was dying (S.M.A.R.T. failure). This one wasn't with 10.7.4 installed on it. I took it out.
After that computer can't boot. In verbose booting I see message "Still waiting for root device".

I have tried tried leaving only this hard drive, and also booting with rd=disk0s1 through rd=disk2s2 options, but it doesn't help.

All lines in verbose mode while loading kexts are begining with:
Reading HFS+ file: [hd(0,2)/System/Library....

And two last lines in verbose mode are:
rooting via boot-uuid from /chosen: E23C68BF-5F68-3568-BRE7-4317E7ADE4D5
Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string</key>IOResourcesMatch</key></string ID="2">boot-uuid-media</string></dict>


Help, how can I fix it?

Navigation

[0] Message Index

Go to full version