VoodooPS2Controller > Bug Reports

Error ApplePS2SynapticsTouchPad not found

<< < (2/4) > >>

I'm having the same problem on a lenovo G530.  The keyboard works fine and the trackpad seems to work for a couple seconds after boot but it quickly stops responding at all.

When I click on the VoodooPS2 prefpane I get "appleps2synapticstouchpad not found" and when I change any of the settings system prefrences will crash.

Any ideas?

Same problem but no keyboard and no touchpad is working.
Very desperate !!!  :'(

My laptop:
Acer Travelmate 6592 with
Synaptics Touchpad

please help me ::)

I am also experiencing this issue.
Keyboard works, touchpad does not.

HP 2510p, iDeneb 10.5.6 updated with iDeneb combo update 10.5.7 & 8 (non-EFI)
Synaptics v6.3 PS/2 touchpad on port 3

Used the method below to ensure AppleACPIPS2Nub no longer runs. Also, there is no EFI partition on the laptop.

--- Quote from: lebidou on May 08, 2009, 02:03:16 AM ---We may have a final solution! The problem came from a modified AppleACPIPlatform.kext that came with iPC and maybe some other "distros" with an ACPIfix; the main problem was it still loaded an instance of AppleACPIPS2Nub class even without the AppleACPIPS2Nub.kext. I got my hand on kexts from a Boot 132 boot cd and it work well with it.

Here is the kexts : ACPI_Fix.zip
It contains AppleACPIPlatform.kext v1.2.4, Vanilla AppleAPIC.kext 1.4 and IOACPIFamily.kext 1.2.0

I hope we finally got it! And thanx to gustavolessa who noticed this.

--- End quote ---

Any suggestions on what else i can try will be appreciated.


I was having the same issues with my touchpad which is also ALPS (dell d610). Here is how i fixed it. I simply tweaked the kext named VoodooPS2Controller.kext a bit and forced all the scrolling flags to true. Also I changed the default mouse pointer speed values so the pointer is much smoother and doesn't jump anymore.

Download the modified VoodooPS2Controller.kext from here:


Now all you have to do is extract this newly downloaded kext to your desktop and then copy - paste it to /System/Library/Extensions/ and overwrite the default VoodooPS2Controller.kext that is already residing there.

You may get a message that this kext was not installed properly and bla bla after you replace, just ignore them and hit OK everytime! Now let's do the final step.

Open terminal and type the following:

sudo -s

[your password]


cd /System/Library/Extensions/

chown -R root:wheel VoodooPS2Controller.kext

chmod -R 755 VoodooPS2Controller.kext

cd /System/Library/

rm -rf Extensions.*

diskutil repairpermissions / {this step may take some time till it reaches 100% so be patient}


Now you have fully working scrolling as well as a much stable touchpad. However you still won't be able to open the customizing panel from preferences. But who needs it now anyway?  :)

Hope this helps.

Is anyone else still having this problem? I still have the problem and I am unable to configure my alps touchpad, even after replacing my ACPI kexts as suggested by a previous post.

The post above mine that had forced scrolling support and slowed down the pointer speed DID work for me, but it's a little too slow. Is there any way to manually change the speed of the touchpad without having to use the prefpane (which still doesn't work for me)?

Thanks in advance.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version