Author Topic: VoodooHDA on MSI Wind U123  (Read 3534 times)

0 Members and 1 Guest are viewing this topic.

rosenbj

  • Entrant
  • Posts: 1
VoodooHDA on MSI Wind U123
« on: May 23, 2009, 05:45:41 PM »
All,

I am having problems getting VoodooHDA to function on my new MSI Wind U123 (upgraded to 2GB RAM).

I have installed iDeneb 1.4 with the iDeneb 10.5.7 Combo upgrade. After adding all the driver packs I have everything working except for audio. Video is 1024x600 with QE/CI. Realtek wireless works great. Trackpad is great.

No appleHDA, HDAenabler or azalia kexts are install.

I used kext helper to install the latest VoodooHDA kext3 0.2.2-042109 but got no sound at all.

The system log shows the following:

cat system.log |grep HDA
May 23 11:28:38 test-macpro31 kernel[0]: Loading VoodooHDA 0.2.2 (based on hdac version 20090401_0132)
May 23 11:28:38 test-macpro31 kernel[0]: VoodooHDADevice[0x367d400]::init
May 23 11:28:38 test-macpro31 kernel[0]: VoodooHDADevice[0x367d400]::probe
May 23 11:28:38 test-macpro31 kernel[0]: VoodooHDADevice[0x367d400]::initHardware
May 23 11:28:38 test-macpro31 kernel[0]: VoodooHDADevice[0x367d400]::stop
May 23 11:28:38 test-macpro31 kernel[0]: VoodooHDADevice[0x367d400]::disableEventSources
May 23 11:28:38 test-macpro31 kernel[0]: VoodooHDADevice[0x367d400]::deactivateAllAudioEngines
May 23 11:28:38 test-macpro31 kernel[0]: VoodooHDADevice[0x367d400]::free
May 23 11:28:38 test-macpro31 kernel[0]: VoodooHDADevice[0x367d400]::deactivateAllAudioEngines

The voodoohdahelper command displays the following.
sudo ./voodoohdahelper -dump
error: IORegistryEntryGetPath returned 0x10000003

When I run the panel application I get the error "Can't get registry-entry path".

Any ideas?

TIA,
JR