Author Topic: org.chameleon.plist.AHCIPortInjector is not loadable  (Read 3590 times)

0 Members and 1 Guest are viewing this topic.

eyvind

  • Member
  • Posts: 50
org.chameleon.plist.AHCIPortInjector is not loadable
« on: May 29, 2009, 07:35:59 AM »
I receive this error at every boot:

kernel extension org.chameleon.plist.AHCIPortInjector is not loadable

My modded AHCI values still seem to load, as my AHCI works without orange icons or other problems. What could this mean?
 
My new notebook:
MSI X-340, Slim as an Air
2 GB Ram, Intel 723 ULV processor (SSE3 capable), Intel 4500MHD Graphics
Running Windows 7 Ultimate 64bit, Ubuntu 9.10 64bit, Currently installing Snow Leopard Vanilla, BackTrack
Currently installing Snow Leopard Vanilla, BackTrack

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: org.chameleon.plist.AHCIPortInjector is not loadable
« Reply #1 on: May 29, 2009, 01:02:46 PM »
AHCIPortInjector gets installed to /Extra/Extensions when you install Chameleon 2.0 RC1 and takes care of the icons for you. There is no longer any need to tamper with the kexts that are installed by the OS in order to fix the icons.

(EDIT: oops, it's actually LegacyAHCIBlockStorage that fixes the icons. I always confuse the two when typing from memory).

You can put back the original AHCI kexts in S/L/E.

Set correct permissions on the /Extra/Extensions folder:

chown -R root:wheel Extra/Extensions
chmod -R 755 Extra/Extensions
« Last Edit: May 29, 2009, 07:25:45 PM by Beerkexd »
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

eyvind

  • Member
  • Posts: 50
Re: org.chameleon.plist.AHCIPortInjector is not loadable
« Reply #2 on: May 29, 2009, 01:59:46 PM »
I'm sorry if I wasn't clear. I infact meant that i modded the AHCIinjector to show ICH7-R instead of just ICH7 (minor cosmetics ;P)

But since the modded name shows up, and everything works, I don't think this is an issue... My kexts in S/L/E are already vanilla (including the AHCIport, etc)
My new notebook:
MSI X-340, Slim as an Air
2 GB Ram, Intel 723 ULV processor (SSE3 capable), Intel 4500MHD Graphics
Running Windows 7 Ultimate 64bit, Ubuntu 9.10 64bit, Currently installing Snow Leopard Vanilla, BackTrack
Currently installing Snow Leopard Vanilla, BackTrack

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: org.chameleon.plist.AHCIPortInjector is not loadable
« Reply #3 on: May 29, 2009, 07:23:25 PM »
It's probably doing that because the permissions on it are wrong - I'm guessing you didn't re-set the permissions on it after editing it.

Open terminal, type sudo -s and then type the above commands. It sets the correct permissions for all the kexts in /extra/extensions.
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

thorazine74

  • Member
  • Posts: 57
Re: org.chameleon.plist.AHCIPortInjector is not loadable
« Reply #4 on: May 30, 2009, 11:58:20 AM »
Is it that needed? I thought Chameleon ignored all permissions required from /Extra/Extensions? At least I dont remember having to fix permissions of the extensions I copied there...
Mac OS X 10.5.6 Retail (Updated to 10.5.7) with Chameleon 2.0 RC1+BootIt NextGen 1.86 (MBR Single Drive)
Gigabyte 73PVM-S2H + C2D + 2 Gb
2 SATA HD (AppleAHCIport.kext) + 1 PATA DVD+RW (DarwinATAPort.kext)
Realtek ALC889 (VoodooHDA.kext)
Geforce 8600GTS (EFI String) PS/2 M & KB: VoodooPS2.kext

eyvind

  • Member
  • Posts: 50
Re: org.chameleon.plist.AHCIPortInjector is not loadable
« Reply #5 on: May 31, 2009, 09:15:53 AM »
Hey thanks for that heads up. Ill try it as soon as I get back from vacation. Until then, I wish good luck to all you contributers and devs :)
My new notebook:
MSI X-340, Slim as an Air
2 GB Ram, Intel 723 ULV processor (SSE3 capable), Intel 4500MHD Graphics
Running Windows 7 Ultimate 64bit, Ubuntu 9.10 64bit, Currently installing Snow Leopard Vanilla, BackTrack
Currently installing Snow Leopard Vanilla, BackTrack

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: org.chameleon.plist.AHCIPortInjector is not loadable
« Reply #6 on: May 31, 2009, 07:45:13 PM »
Is it that needed? I thought Chameleon ignored all permissions required from /Extra/Extensions? At least I dont remember having to fix permissions of the extensions I copied there...

I heard that too, that it ignores permissions on the kexts. But until this appears in official docs or gets confirmed by voodoo labs dev I don't believe 100% in anything that's posted about Chameleon.

Whatever it is, the kext has become unloadable because of the changes that Eyvind has made to it. I thought fixing permissions and setting proper ownership is a good start.
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

zef

  • Administrator
  • Posts: 265
Re: org.chameleon.plist.AHCIPortInjector is not loadable
« Reply #7 on: May 31, 2009, 09:26:18 PM »
The booter's filesystem driver can't handle permission/ownership info. If you encounter such errors, the issue must be somewhere else.
ASUS P8Z68-V PRO/GEN3 | i5-2500k | 16GB RAM | GTX560 | Keyboard | Mouse | Devilsound DAC