Author Topic: Weird Fix for VoodooPS2Controller Stuck Key Problems  (Read 4124 times)

0 Members and 1 Guest are viewing this topic.


  • Entrant
  • Posts: 2
Weird Fix for VoodooPS2Controller Stuck Key Problems
« on: June 09, 2009, 12:15:22 AM »
I followed this mini how-to (http://forum.voodooprojects.org/index.php/topic,257.0.html) but there was any AppleACPIPS2Nub.kext. After reboot -f, the trackpad, mouse and keyboad are not working. However when I boot off CD (iDeneb v1.4) and let it go, I got trackpad, mouse and keyboard working ???

I tried other fixes:
 - replaced 'safe boot' to 'console' -> got trackpad working, but stuck keys (@@@... at verbose mode, and 777... in Mac Os)
 - tried 'F12 not open tray fix' (http://forum.voodooprojects.org/index.php/topic,115.msg745.html#msg745) -> always got crashed
 - not having problem with 'preference pane settings not saved' but did (http://forum.voodooprojects.org/index.php/topic,99.msg567.html#msg567)
 - tried ACPI_Fix (http://forum.voodooprojects.org/index.php/topic,80.msg1155.html#msg1155) -> no help
 - want to 'remove the ApplePS2Controller.kext from my EFI partition' -> don't know how (i'm very new here)

At last, thanks to all VoodooLabs for your awesome job to our community. This PS2Controller is way better than 2-finger Scrolling thread earlier in InsanelyMac forum. Cheers...

P.S.: I'm using Toshiba A135-S4677... originally installed from iATKOS 5i 10.5.5 DVD... have been updated to 10.5.7 (combo) with minor fixes (dmg mounting issue)... tried 2-finger scrolling and removed it (restore back to original ApplePS2Controller.kext, remove FFScroll from System Preferences, and remove FFScrollDaemon from StartupItems)

(Update): I guess when booting from DVD, it uses Chameleon 1.0.11 and I'm using v2.0RC1.

(Update 07/22/09) Find Chameleon 1.0.11 package, install, and trackpad works perfectly. Thanks to voodooLabs.
« Last Edit: July 22, 2009, 08:30:34 PM by AZBigK »