Chameleon > Bug Reports

Chameleon 2.0RC1 and RC2 prevents sleep - on Windows!

<< < (2/6) > >>

Help!  I'm having the same problem with Windows 7 x64 RTM.  When I had RC1 of Chameleon, everything worked fine.

Leopard won't sleep either, the display goes off and the computer gets stuck with all fans spinning, etc.

I would like to get my sleep working again.  I use it all the time.

When i try to put Windows 7 x86 RTM Ultimate to sleep, it comes back from sleep instantly but only if Windows is NOT the active partition:

With Chameleon 2.0 RCx: Sleep Fail
With GRUB (without makeactive option): Sleep Fail
With GRUB & set makeactive: Sleep Works.
With "Windows 7 loader": Sleep Works

Then, i think that Active/Not Active flag in the partition/hard drive is the trouble.

Hmm... Interesting idea... I'll test that now :)

If only there was a way to make the windows partition active, then boot the chameleon partition. THe problem is that if you do this, when you select windows from the chameleon menu, you get an endless loop...

Maybe its possible to install chameleon the system partition windows 7 creates ? But this defeats the purpose of an invisible extra partition (efi partition)

Gringo Vermelho:
I don't understand how it can be possible for Chameleon to affect an OS that's installed on a separate hard drive, specially because you're not even using Chameleon to boot that drive. Sounds more like behavior of a virus than that of a boot loader.

Try unplugging the drive that has Chameleon on it and do a CMOS reset, don't forget to re-set your BIOS settings.

Then boot Windows 7 and try putting it to sleep.

I have Windows 7 and Leopard installed on 1 HD.  Flagging the 2nd partition (windows), Windows sleeps perfectly. Flag 1st partition (chameleon bootloader) neither OS sleeps. RC 1 was fine when it came to sleeping.  RC 2 broke sleep.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version