Author Topic: Cant get registry entry path error..  (Read 11926 times)

0 Members and 1 Guest are viewing this topic.


  • Entrant
  • Posts: 2
Cant get registry entry path error..
« on: June 27, 2009, 04:38:07 PM »
Where am i going wrong..and how to rectify this....


  • Entrant
  • Posts: 1
Re: Cant get registry entry path error..
« Reply #1 on: July 10, 2009, 04:41:33 AM »
I've got the same problem.

I had onboard audio enabled and I want to get my PCI Xfi working.  When I had onboard enabled voodooHDA seemed to be working somewhat, the audio devices were there but I couldn't hear anything.  I disabled the onboard audio in the BIOS thinking that voodooHDA must just be working on the first audio chip it finds.

Now voodoohdahelper returns
error: IORegistryEntryGetPath returned 0x10000003

and I have no audio devices.  I have tried removing and reinstalling the kext, repaired permissions, rebooted many times.  I've tried searching that error in Google and on these boards, but can't come up with anything.

VoodooHDA.perfPane gives the following error.
Can't get registry-entry path

Any advice or opinions on the subject would be greatly appreciated. I'm running iPC 10.5.6 ppf5 using vanilla kernel. I have not done software updates.

So I went back to the BIOS and re-enabled the onboard audio which now works.  Still can't get the X-Fi to work though, which is the one I really want to use :P
« Last Edit: July 10, 2009, 05:51:52 AM by Cyaegha »