Author Topic: how to get the creative x-fi running  (Read 4791 times)

0 Members and 1 Guest are viewing this topic.

paofneele

  • Entrant
  • Posts: 2
how to get the creative x-fi running
« on: July 12, 2009, 02:10:48 PM »
Hi dear all,

I searched for it but found only one success posting, so let me please ask, if
the creative x-fi pci is supported and how to get it to a functional state.

I'm using iAtkos 10.5.7 with Chameleon 2
any tips how to get this card working are extremly welcome.

what i tried so far:
-copied IOAudioFamily.kext and OSvKernDSPLib.kext from S/L/E to /E/E
-installed VoodooHDA0.2.2 with kext helper
-copied VoodooHDA.kext from /S/L/E to /E/E
-rebooted with -f

I'm only getting sound out of my Asus P5K onboard sound plug. My x-fi is still silent.

did I miss something? Am I completly wrong?
If you feel (like me) that I dont know what I did there, please point me to the correct links to read and learn about these topics. OSX86 is brand new for me...


have a nice week
PaofNeele

ESP

  • Entrant
  • Posts: 2
Re: how to get the creative x-fi running
« Reply #1 on: July 14, 2009, 03:24:35 AM »
I had to deactivate my onboard audio through the BIOS before the VoodooHDA kext would work for the X-Fi (though maybe some futzing around in System Prefs to change the output device may do the job as well). As for installation, I did nothing more than drop the extension into kext helper and reboot (may have been with -f; wouldn't hurt to add it).

I have my doubts about the PCI version working though. The PCI-E X-Fi cards use the newer EMU20k2 chipset, have an actual HDA connector for case-front audio, and work in Vista/7 with the generic driver. This leads me to believe that they support Intel's HD Audio spec to some measure (and I wouldn't be surprised if this was a Vista-logo demand from Microsoft).

paofneele

  • Entrant
  • Posts: 2
Re: how to get the creative x-fi running
« Reply #2 on: July 15, 2009, 03:55:14 PM »
thanks a lot!
I'll give it a try when I'm back home.

If it works, you'll buy you a virtual beer or two ;-)

skydrone

  • Observer
  • Posts: 12
Re: how to get the creative x-fi running
« Reply #3 on: July 17, 2009, 11:04:18 AM »
I really need, at least, the digital output of my x-fi pciex working.

Any hope?  ???