overdue-scratch

Author Topic: Latest Chameleon fails to load FakeSMC  (Read 6422 times)

0 Members and 1 Guest are viewing this topic.

dronmbi

  • Entrant
  • Posts: 5
Latest Chameleon fails to load FakeSMC
« on: January 22, 2013, 09:26:38 PM »
I was always building Chameleon myself from svn and the latest version I had on my harddisk was 2.1svn (svn-r2050)
Recently I decided to give it a try with svn version 2170, but it stucks with message
"ACPI_SMC_PlatformPlugin::registerLPCDriver - failed to locate SMC driver"
Same thing happens with 2160 and 2150.

Am I missing something? The only thing I've changed on my boot partition was the 'boot' binary. Rolling back to 2050 solves the issue.
Theoretically I can nail it down to a specific svn version but it's been more than a hundred of them since 2050. Were there any major changes that could have affected extension loading? My FakeSMC is located on the same partition as Chameleon (first one, hfs gpt efi) all other kexts are on the Mac OS partition (second one). I'm booting 10.8.2, the only other custom kext is VoodooHDA.

Update: I've just realized that I cannot build older versions anymore because they are incompatible with Xcode 4.5.2
« Last Edit: January 22, 2013, 09:35:43 PM by dronmbi »

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: Latest Chameleon fails to load FakeSMC
« Reply #1 on: January 22, 2013, 10:33:18 PM »
Boot with UseKernelCache=n or place fakesmc.kext in /System/Library/Extensions.
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

dronmbi

  • Entrant
  • Posts: 5
Re: Latest Chameleon fails to load FakeSMC
« Reply #2 on: January 23, 2013, 09:40:12 AM »
Thanks a lot, UseKernelCache=No did the trick!

BootHelp.txt says it's off by default, which is a bit confusing :)

AniV

  • Observer
  • Posts: 18
Re: Latest Chameleon fails to load FakeSMC
« Reply #3 on: January 29, 2013, 01:40:24 AM »
Thanks, I had the same problem. That change was a rather bold decision, IMHO. Meaning, after chameleon update people just get stuck and cannot boot anymore. Is there any technical reason? I've noticed that r2070 doesn't require 'UseKernelCache=No'. :P
"Life is what happens to you while you're busy making other plans". .