Author Topic: strange behavior [solved]  (Read 1989 times)

0 Members and 1 Guest are viewing this topic.


  • Entrant
  • Posts: 2
strange behavior [solved]
« on: February 08, 2013, 12:09:18 AM »
I have a strange thing happening when booting my Hack with Chameleon 2.2 r2170. It always adds the -x flag by itself when booting, so I alway end up in Safe mode. When I press TAB to get to the commando line in Chameleon, there is already -x when it opens. I looked at the org.chameleon.boot.plist and there is no -x in there under kernel flats.

So, where is this -x comming from?

Thanks for helping... (I hope)
« Last Edit: February 08, 2013, 10:55:52 AM by knaar00 »

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: strange behavior
« Reply #1 on: February 08, 2013, 12:42:41 AM »
Look at /Library/Preferences/SystemConfiguration/

Are you using the NVRAM module? Maybe the x flag got stuck in NVRAM somehow.
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon:,649
Make your own Chameleon boot CD:,484.msg2131.html#msg2131


  • Entrant
  • Posts: 2
Re: strange behavior
« Reply #2 on: February 08, 2013, 10:55:18 AM »
Problem solved!

Trashed the nvram plist file that was created in Extra and did a clean reboot. You are right that Chameleon saves the state (safe or regular boot) in the nvram file.

Thank for your help !