Author Topic: Sapphire ATI Radeon HD 6870 Flex only 3 monitors working (r2248trunk)  (Read 1642 times)

0 Members and 1 Guest are viewing this topic.

AuralArch

  • Observer
  • Posts: 12
I'm not exactly positive whether this is the appropriate place to report this...  And there doesn't seem to be an official and/or formal format expected.  But I apologize if I've missed something.

Symtoms: Only 3 of my 5 displays turn on & work when I boot using Chameleon 2.2 r2248.  IORegExp does show a 4 port,  but the 4th port doesn't work even if it's the only one connected to a display (I have it set to boot -v, so this happens as soon as the OS GUI loads- up to that point that display has been the primary one- showing the boot messages).

The reason I blame this problem on this version of Chameleon is because other bootloaders and versions of Chameleon have been giving me full functionality of all of my displays for years- since I got the card.  I didn't change any settings, just updated the bootloader.  In the past it has always been necessary to specify the framebuffer and number of ports- which the logs report that 5 ports are being set, but by the time it loads one has disappeared (and one rendered unusable).

My card is not is not to spec though- I mean, I don't believe most of the 6870s have 5 ports... (it has 2 DVI ports, 1 single & one double, an HDMI and 2 mini-DisplayPorts).  And actually mine is capable of running 3 DVI monitors in "Eyefinity" mode without any active adapters- apparently it has an active adapter built into the HDMI port; that's why it's called "Flex". However, as I stated I haven't really had any trouble until now.

I'm just switching back to my old bootloader, no big deal- I didn't really need to change it... I just got bored I guess. But I figured it was worth posting here.  I'd be happy to post any further info if anyone would find it useful.