Chameleon > Bug Reports

PS2 Mouse killed after 2265 revision


I'm using PS2 KB+Mouse because I don't want computer to awake after Mouse or keyb movement, just only power button. So I don't want to use any USB solution.
In rev 2265 PS2 mouse works ok but since 2266+ Keyboard works, but mouse doesn't.
I wrote before in svn 19xx revisions happened the same and it was fixed. But you see...the problem reappears.  :(
Is there any chance to resolve it again?

My PS2 related kexts:

com.Apple.driver.PS2Keyboard (1.1.0)
com.Apple.driver.PS2Mouse (1.2.0)
com.Apple.driver.ApplePS2controller (1.1.5)
com.yourcompany.driver.AppleACPIPS2Nub (1.0.0d1)

I tested until rev 2281 and no luck  :( I had to revert to my latest working rev.2265.

Rev. 2321 still doesn't work... :(
Does anyone know if this could be fixed in a near future?  8)

Gringo Vermelho:

Try setting PS2RestartFix=y  - i don't know what this flag does but it's something to try.

I haven't used PS2 devices since the last century so I can't help you any further.

Thanks...but it doesn't work at all!

I use PS2 mouse because USB mouse wakes up my computer from sleep when the mouse is moved not intentionally (I hate it).

Anyone knows a way to deactivate this behavior using USB kb+mouse? I don't want to wake up PC when sometime or somewhere touch the mouse...or keyboard presskey. Perhaps an DSDT patch?


Revision 2378 still doesn't work.  :-[


[0] Message Index

Go to full version