overdue-scratch

Author Topic: [SOLVED] Windows XP MBR Boot Issues  (Read 5135 times)

0 Members and 1 Guest are viewing this topic.

Plx

  • Entrant
  • Posts: 1
[SOLVED] Windows XP MBR Boot Issues
« on: April 10, 2009, 06:28:29 AM »
(Hope this is the right place for this  :) )

Hello all

I am having a problem booting in to XP with the new Chameleon 2. It detects both the NTFS & OS X drives fine, but booting in to XP results in a flashing cursor. I have set the XP to be first in the BIOS drive list, tried fixboot & fixmbr from the XP recovery console, but no joy. I have had other dual boot set ups running before with the Darwin loader, but I'm stumped here. XP drive is Master PATA, OS X is SATA, both MBR. Leo4AllV5 on AMD X2.

Thanks


Moderator Edit: Please be descriptive. SATA for MacOS and IDE for Windows says something. SATA mode and partition scheme for your OSs is where it's at. Boot issues are not only Chameleon-specific

Moderator Edit 2: Duplicate topics merged, duplicate posts removed.
« Last Edit: May 27, 2009, 03:27:53 PM by rocksteady »

TequilaKez

  • Entrant
  • Posts: 2
Re: XP Flashing cursor problem
« Reply #1 on: April 11, 2009, 05:47:39 AM »
Yeah I get the same thing.

I have a osx installed on a SATA drive and XP on an IDE drive. Until now i've been just swapping drive order in bios to boot different systems after I screwed my chain0 setup by reinstalling leopard.

Both drives boot fine normally. Only the OSX drive will boot properly from chameleon, the XP drive just hangs at a flashing cursor.



Crady

  • Entrant
  • Posts: 1
Win XP pro does not boot from Chameleon :(
« Reply #2 on: May 22, 2009, 09:10:53 PM »
Hi!

My first HDD has 2 HFS+ partitions with both a working system installed.

My second HDD contains one NTFS partition and one HFS+ partition. All partitions are created in MBR format.

If I use my BIOS boot selector I can boot either Win XP directly or one of my Leopard Systems with Chameleon.

But Chameleon is not able to boot Win XP on my 2nd HDD...

Any clues?

DooV

  • Member
  • Posts: 34
Re: Win XP pro does not boot from Chameleon :(
« Reply #3 on: May 23, 2009, 11:49:25 AM »
It's not a bug. Chameleon 2 RC1 simply lacks that feature. I think is supposed to work in future versions. The only solution at the moment for booting XP from a different disk is making a small HFS+ partition in the XP disk and install Chameleon 2 RC1 there. Once done if you choose that disk in the bios you'll be able to boot XP, and Os X without problems.
« Last Edit: May 27, 2009, 03:29:59 PM by rocksteady »

Zark!

  • Entrant
  • Posts: 4
Hi, I have a custom built compy, (Intel Dual processor, Gigabyte EP45-UD3P Mother board, Asus EN9600GT graphics), Running (on first drive, GUID) Chameleon 2.0, Leopard 10.5.6 (still fixing 10.5.7 on another drive), Windows XP SP3 on drive 2 (Disk utility says this drive is MBR -Master boot record, but I remember formatting it as NTFS when I installed) I am new to all of this however, please correct any mistakes I've made.

I boot and Chameleon shows the different available drives, Leopard runs fine, but if I go to the windows drive, the screen sits as a black "DOS style" screen, with a flashing cursor at top left, and when I type ctrl-alt-del, the system restarts, is there something else I should type here (besides the obvious; enter, esc, etc) ? or is the problem somewhere else? (I can boot to Windows fine through the BIOS).

I've done the obvious, like reinstalling chameleon, and trying with Leopard on a different drive, but I haven't yet had time to reinstall Windows from scratch. I guess, this is what I will have to do if it comes to it, and there are other options than chameleon if it's related to my specific hardware/setup, but, it seems to be by far the best available right now. If there are other things I should add here please post below...
« Last Edit: May 27, 2009, 01:25:34 PM by Zark! »

Zark!

  • Entrant
  • Posts: 4
Re: Windows XP MBR Boot Issues
« Reply #5 on: May 27, 2009, 07:40:38 AM »
OK! A solution, awesome!  :D
This has been bugging me,
Will go try right now.

Zark!

  • Entrant
  • Posts: 4
SOLUTION.
« Reply #6 on: May 27, 2009, 01:24:29 PM »
Looked around a whole lot more, and found this: http://www.insanelymac.com//forum/index.php?showtopic=5056

Turns out it was the two disk setup, and not exactly a bug. Though will likely be fixed in next version of Cham.  ;)

theipodpeople

  • Entrant
  • Posts: 1
Re: [SOLVED] Windows XP MBR Boot Issues
« Reply #7 on: May 29, 2009, 08:49:39 AM »
This doesn't cause a new partition Icon to come up in the Chameleon bootloader does it? Right now I'm running OSX 10.5.6 retail on a Pentium 4 from a sata drive, using the EFI partition. I've got a second ide drive with xp that won't boot from chameleon. I FINALLY got everything looking pretty decent except for that damn windows xp icon! If it does would it be worth it just to wait for a Chameleon update instead?

badmax

  • Entrant
  • Posts: 3
Re: Win XP pro does not boot from Chameleon :(
« Reply #8 on: October 10, 2009, 02:22:59 PM »
please clarify.
does the hfs+ partition need to be the first, middle or last partition? or not important?
the meaning of install, is to copy the boot file? or do the full install with the extension and setting the boot0+boot1h?
does this method take over for what is installed on the GPT drive that has OS X installed?
so the EFI /extras, extensions, dsdt need to be moved?
do we need to disable the original Chameleon install on the GPT disk?

thanks

It's not a bug. Chameleon 2 RC1 simply lacks that feature. I think is supposed to work in future versions. The only solution at the moment for booting XP from a different disk is making a small HFS+ partition in the XP disk and install Chameleon 2 RC1 there. Once done if you choose that disk in the bios you'll be able to boot XP, and Os X without problems.