Chameleon > General Discussion

Chameleon countdown is very slow

(1/1)

Windows04:
Hi everybody,

I installed Macintosh on my new pc with a GA-EX58-UD5 motherboard and the Timeout key in my com.apple.boot.plist is 5 seconds. But when the chameleon bootscreen comes up, the countdown is very slow and only after about 20 seconds macintosh boots automatically... Very weird :s... does anybody has that problem also?

LEN:
Same issue here with the same motherboard.
It never worked for me since 2009 till now with latest chameleon.

This is my org.chameleon.Boot.plist:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
   <key>CSTUsingSystemIO</key>
   <string>Yes</string>
   <key>EthernetBuiltIn</key>
   <string>Yes</string>
   <key>GenerateCStates</key>
   <string>Yes</string>
   <key>GeneratePStates</key>
   <string>Yes</string>
   <key>Graphics Mode</key>
   <string>2560x1440x32</string>
   <key>GraphicsEnabler</key>
   <string>Yes</string>
   <key>Kernel</key>
   <string>mach_kernel</string>
   <key>Kernel Flags</key>
   <string>darkwake=0</string>
   <key>KeyLayout</key>
   <string>mac-de</string>
   <key>PciRoot</key>
   <string>1</string>
   <key>SystemId</key>
   <string>00000000-0000-1000-8000-00xxxxxxx</string>
   <key>Theme</key>
   <string>wetOS-light</string>
   <key>Timeout</key>
   <string>1</string>
   <key>UseKernelCache</key>
   <string>Yes</string>
</dict>
</plist>


I appreciate your help.

Thanks
Len

Blackosx:
I haven't used the timeout option for a long time as I'm always booting directly to the device selection screen so I can choose which system to boot. But if I remember this was discussed before and from memory I think the timeout value, when used with the GUI, doesn't actually reflect genuine seconds, but an approximate count. 

If you want to check the source then maybe a starting point would be the animateProgressBar() function in /i386/boot2/gui.c ?

A workaround might be to disable the GUI and use the darwin text loader, or maybe if you always want to have Chameleon automatically boot your OS without intervention then use the Quiet Boot option.

Maybe it's something to do with the MTRRs as discussed here?

I'll try it out on my system and see what happens.

LEN:
Thanks for trying to help!


--- Quote ---Maybe it's something to do with the MTRRs as discussed here?
--- End quote ---

I think it's the same issue!

Navigation

[0] Message Index

Go to full version