overdue-scratch

Author Topic: Synaptic trackpad (Asus A8sc) : Tap is "too long"  (Read 5573 times)

0 Members and 1 Guest are viewing this topic.

Wiwi

  • Entrant
  • Posts: 4
Synaptic trackpad (Asus A8sc) : Tap is "too long"
« on: April 11, 2009, 01:56:47 PM »
Hi all, first many thanks for this kext, and all others, all your work for OSX86...

Kext load fine and works fine, even 2fingers scrolling !

Only one problem : After activating "tap to clic" (sorry i'm french), tap works but take a long time, like if i was holding / clicking about one second. So i have to let the cursor one second on buttons to "clic" them, and tap on dock is impossible because of that : menu appears like if i was holding...

That's all !Hi all, first many thanks for this kext, and all others, all your work for OSX86...

Kext loads fine and works fine, even 2fingers scrolling !

Only one problem : After activating "tap to clic" (sorry i'm french), tap works but take a long time, like if i was holding / clicking about one second. So i have to let the cursor one second on buttons to "clic" them, and tap on dock is impossible because of that : menu appears like if i was holding...

That's all !

Wiwi

  • Entrant
  • Posts: 4
Re: Synaptic trackpad (Asus A8sc) : Tap is "too long"
« Reply #1 on: April 11, 2009, 02:00:20 PM »
Modify MAxTapTime value in plist seems to help, but even after 12 reboots and modifications, it's still to long or o short (no tap).

In which units are these values ?
Can you post a short description of differents values please ?

mackerintel

  • VoodooLabs
  • Posts: 38
Re: Synaptic trackpad (Asus A8sc) : Tap is "too long"
« Reply #2 on: April 11, 2009, 02:13:19 PM »
Your problem comes from the fact that kext has to wait to be sure that you don't want to perform "tap & drag" gesture. You can either disable dragging gesture or make this time shorter by decreasing "double click time" in the Apples prefpane.
@Wiwi: you can use prefpane for finding the right value, then you can retrieve it with ioreg -lw0.

Wiwi

  • Entrant
  • Posts: 4
Re: Synaptic trackpad (Asus A8sc) : Tap is "too long"
« Reply #3 on: April 12, 2009, 01:03:53 AM »
Thanks it was so easy...

Things seems to become too easy now !

mackerintel

  • VoodooLabs
  • Posts: 38
Re: Synaptic trackpad (Asus A8sc) : Tap is "too long"
« Reply #4 on: April 19, 2009, 11:38:42 PM »
I know where the problem comes from and will bugfix ASAP

lebidou

  • Resident
  • Posts: 133
Re: Synaptic trackpad (Asus A8sc) : Tap is "too long"
« Reply #5 on: April 20, 2009, 12:16:10 AM »
ah thank you mackerintel !

MtMCooLBG

  • Entrant
  • Posts: 1
Re: Synaptic trackpad (Asus A8sc) : Tap is "too long"
« Reply #6 on: July 25, 2009, 10:10:39 AM »
Well that taping problem was fixed in my case when i increased the double click speed, in the original Trackpad prefpane, at maximum. Now it seems that all works perfect.

Dell Inspiron 1520
Somekind of synaptic touchpad.
XxX Universal 10.5.6 (updated to 10.5.7 vanilla)

dvavd

  • Entrant
  • Posts: 1
Re: Synaptic trackpad (Asus A8sc) : Tap is "too long"
« Reply #7 on: July 26, 2009, 08:55:11 AM »
That's the most annoying bug for me. When Double-Click Speed is set to Fast stacks don't spring back to Dock by tap on triangle there and double-click itself isn't comfy anymore. Even worse, double-click preference somehow affects speed of double-click with mouse.