VoodooLabs > News

VoodooTSCSync for Snow Leopard -- New Release

<< < (2/6) > >>

what quad core has a TSC synchronization issue?
if u have one that does, no, you'd change it to 3 , so that it loads after the last cpu is activated.

Unfortunately, it doesn't work for me. I have a laptop sporting a T4200. Should it work? Anyway, kernel panic when booting with "-v -f arch=i386":

Does work with "-v -f arch=i386 cpus=1" though.

Confirmed! Works well on a Dell Latitude D820 that's been behaving pretty ugly before this one. Intermittent mouse, video, and keyboard, repeating chars while typing, etc. to name just a few symptoms. No more stuttering with this kext loaded, both CPUs are active, bingo! The world is saved again.

Thanks a lot guys, keep up the great work! ;)

Hey guys,

I've tried it on the Dell Latitude 830 as well (Core2Duo T9500 Penryn), and it loads and runs successfully.

I'm not sure if I really need to use this kext or not. I've first tried it on a D820 which had pretty serious stuttering issues. You could only get rid of them using cpus=1, before this kext, which fixed it.

On my D830 on the other hand, I've never had those problems. What I do have though are random USB and PS2 controller problems. Here's a list:

A. Keyboard problem:

My laptop keyboard sometimes goes AWOL. I can't type, though the Ctrl+arrow shortcuts still work in Expose, but I can't type. If I leave a console window open and in focus for a long period, and leave the laptop idle, it sometimes starts to type rows of "7777777777777777777777" in the console. Yes, it's funny. :)

B. USB problems:
On boot, I often (but randomly, not always) get messages like:

USBF:      1.417   AppleUSBUHCI[0x84ac000]::start unable to initialize UIM

and then some of my USB ports will fail. These might come from a potential IRQ problem though (I must learn more DSDT editing). I have a hunch that my USB IRQ conflicts with my HPET, unfortunately. When I use a HPET-edited DSDT (only the "new HPET" style works), I lose my USB ports entirely. That's why I'm using netkas' HPETDevice kext and my original, unedited DSDT.

I can't put the laptop into hibernate (deep sleep) unless I previously remove everything from my USB ports. If entering hybernate still fails, I try it twice, and usually succeed on second try.

C. PS/2 controller problems:

During normal operation, I sometimes get messages like:

ApplePS2Mouse: Unexpected data from PS/2 controller.

I'm using the newer 32/64-bit com.yourcompany.driver.AppleACPIPS2Nub (1.0.0d1)
However, my touchpad and pointing stick always seem to work properly, it's just the keyboard that gets messed up on occasion, as stated above.

I wonder if any of these problems have anything to do with TSCSync.
On load, my dmesg says:

Current tsc from rdtsc64() is 48035125190. Rendezvouing..
VoodooTSCSyn::doTsc(): stamp_tsc was called: 2 times

Is this good or bad? :) Do I need this kext at all? Will it help with my problems?
I've just loaded it today for the first time, and I'll keep on watching.
Please do excuse my relative n00bness, the Hac scene is still all new grounds to me.



--- Quote from: EtHeO on December 01, 2009, 11:23:04 PM ---Unfortunately, it doesn't work for me. I have a laptop sporting a T4200. Should it work? Anyway, kernel panic when booting with "-v -f arch=i386":

Does work with "-v -f arch=i386 cpus=1" though.

--- End quote ---
So this won't work for Pentium Dual Core?


[0] Message Index

[#] Next page

[*] Previous page

Go to full version