overdue-scratch

Author Topic: "boot ignore caches" for default ?  (Read 15934 times)

0 Members and 1 Guest are viewing this topic.

CEOS

  • Member
  • Posts: 49
"boot ignore caches" for default ?
« on: September 30, 2009, 06:10:56 PM »
plz help

the sound of my mainboard (gigabyte ep45-ds3r)  just work if i boot in -f (boot ignore caches) mode .

but its really annoying to change options every start.....

that´s why i try to put this option in my boot.plist, but it doesn´t work !
Code: [Select]
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>arch=i386</string>
        <string>-f</string>
<key>Timeout</key>
<string>10</string>
<key>Rescan Prompt</key>
<string>yes</string>
<key>device-properties</key>
<string>4e0200000100000001000000420200000d00000002010c00d041030a010000000101060000010101060000007fff04000e0000004e00560050004d0000002000000001000000000000000000000000000000000000000000000000000000220000005600520041004d002c0074006f00740061006c00730069007a006500000008000000000000201c0000006400650076006900630065005f00740079007000650000000f0000004e5644412c506172656e740e0000006e0061006d00650000000b000000646973706c617922000000400030002c006400650076006900630065005f00740079007000650000000b000000646973706c617922000000400031002c006400650076006900630065005f00740079007000650000000b000000646973706c6179100000006d006f00640065006c0000000b0000003935303020475420000000400031002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d616314000000400030002c006e0061006d0065000000120000004e5644412c446973706c61792d4114000000400031002c006e0061006d0065000000120000004e5644412c446973706c61792d4220000000400030002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d6163100000004e00560043004100500000001800000004000000000003000c00000000000007000000001e00000072006f006d002d007200650076006900730069006f006e0000001f00000039353030204754204f70656e474c20456e67696e65205b4546495d</string>
</dict>
</plist>

is there any way to boot use -f mode for default ?
My Hackintosh: • Intel Core2Quad Q6600 (g0) • PNY 8800gts 512 (g92) • Gigabyte Ga EP45-DS3R (Rev 1; BIOS v. f11e) • 2x2gb OCZ 1066MHz DDR3 • D-Link DWA 547 RangeBooster N

Drives: • HL-DT-STDVD-RAM GH22LS30  • SAMSUNG HD250HJ : Windows 7 Ultimate x64 • SAMSUNG HD161HJ :  Snow Leopard 10.6.3 • SAMSUNG HD103UJ : Backup

Kabyl

  • VoodooLabs
  • Posts: 158
Re: "boot ignore caches" for default ?
« Reply #1 on: September 30, 2009, 06:34:57 PM »
Your plist has mistakes, and why don't you fix the need for the -f option?

CEOS

  • Member
  • Posts: 49
Re: "boot ignore caches" for default ?
« Reply #2 on: September 30, 2009, 07:41:09 PM »
Hi Kabyl (are you the OSX86 legend Kabyl ;) ?)

thank you for your quick reply.

Quote
and why don't you fix the need for the -f option?

i have no idea how to fix it.
every time i use "wathever" to build the extension.mkext file, sound doesn´t work.
i try terminal, mkexttool OSX86 tool, boot without the file and nothing works.

the only way to get sound working for me is to boot in -f mode.

maybe the problem is that i install chameleon rc3 on a usb stick....


Quote
Your plist has mistakes

can you please explain what i did wrong ?
My Hackintosh: • Intel Core2Quad Q6600 (g0) • PNY 8800gts 512 (g92) • Gigabyte Ga EP45-DS3R (Rev 1; BIOS v. f11e) • 2x2gb OCZ 1066MHz DDR3 • D-Link DWA 547 RangeBooster N

Drives: • HL-DT-STDVD-RAM GH22LS30  • SAMSUNG HD250HJ : Windows 7 Ultimate x64 • SAMSUNG HD161HJ :  Snow Leopard 10.6.3 • SAMSUNG HD103UJ : Backup

Blackosx

  • Forum Moderator
  • Posts: 1150
Re: "boot ignore caches" for default ?
« Reply #3 on: September 30, 2009, 10:02:45 PM »
can you please explain what i did wrong ?
Just quickly looking at this, the Kernel Flags in your com.apple.Boot.plist are on two lines, it should be in one line so to use your example, yours should read...

   <key>Kernel Flags</key>
   <string>arch=i386 -f</string>

As for your audio, that's not an issue for this forum, but something to do with your system setup, DSDT or choice of kexts etc.. Search one of the osx86 forums for somebody else who is using your mobo and see what they have done to get audio working.
« Last Edit: October 01, 2009, 01:15:49 PM by Blackosx »
10.10.5 / 10.11 GM1 | Asus Maximum IV Gene-Z | i7-2600 3.40GHz | 4GB | Radeon 5770 1GB

rocksteady

  • Global Moderator
  • Posts: 233
  • Root Down
Re: "boot ignore caches" for default ?
« Reply #4 on: October 01, 2009, 12:43:00 PM »
can you please explain what i did wrong ?

Kernel flags + booter options is not the same thing.

Read the FAQ, Distemperus efforts on documentation + BootHelp.txt in order to understand the basics (how chameleon works). If you don't understand the basics you'll be hitting the same wall for ever.

Both are written as simply as possible, don't look for fancy commands/scripts before you understand how things work, it'll only end in tears.
Stop bitching, start coding or documenting or both..

P5Q-EM : Q6600 : 8GB RAM : 8800GT : SATA Drives

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: "boot ignore caches" for default ?
« Reply #5 on: October 02, 2009, 06:07:42 AM »
This won't break anything:

Boot from your 10.6 install DVD, start Disk Utility and do a "repair permissions" on your system partition.

Then reboot into 10.6 (still with -f) and type this in terminal:

sudo kextcache -v 1 -t -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions

Then try rebooting without -f
« Last Edit: October 02, 2009, 06:15:20 AM by Gringo Vermelho »
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

CEOS

  • Member
  • Posts: 49
Re: "boot ignore caches" for default ?
« Reply #6 on: October 02, 2009, 12:45:41 PM »
Quote
his won't break anything:

Boot from your 10.6 install DVD, start Disk Utility and do a "repair permissions" on your system partition.

Then reboot into 10.6 (still with -f) and type this in terminal:

sudo kextcache -v 1 -t -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions

Then try rebooting without -f

this won´t work for me caus i installed chameleon to a usb key....

and if i try to rebuild the cache on the key i get an error
think i don´t have the permissions
My Hackintosh: • Intel Core2Quad Q6600 (g0) • PNY 8800gts 512 (g92) • Gigabyte Ga EP45-DS3R (Rev 1; BIOS v. f11e) • 2x2gb OCZ 1066MHz DDR3 • D-Link DWA 547 RangeBooster N

Drives: • HL-DT-STDVD-RAM GH22LS30  • SAMSUNG HD250HJ : Windows 7 Ultimate x64 • SAMSUNG HD161HJ :  Snow Leopard 10.6.3 • SAMSUNG HD103UJ : Backup

Dalton63841

  • Observer
  • Posts: 14
Re: "boot ignore caches" for default ?
« Reply #7 on: October 02, 2009, 09:02:39 PM »
Quote
his won't break anything:

Boot from your 10.6 install DVD, start Disk Utility and do a "repair permissions" on your system partition.

Then reboot into 10.6 (still with -f) and type this in terminal:

sudo kextcache -v 1 -t -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions

Then try rebooting without -f

this won´t work for me caus i installed chameleon to a usb key....

and if i try to rebuild the cache on the key i get an error
think i don´t have the permissions

Open terminal and set permissions on the usb key like this:
sudo -s
/usr/sbin/vsdbutil -a /Volumes/(usbkey)

Then try building kextcache again with:

sudo kextcache -v 1 -t -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions

CEOS

  • Member
  • Posts: 49
Re: "boot ignore caches" for default ?
« Reply #8 on: October 03, 2009, 02:33:41 PM »
Quote
his won't break anything:

Boot from your 10.6 install DVD, start Disk Utility and do a "repair permissions" on your system partition.

Then reboot into 10.6 (still with -f) and type this in terminal:

sudo kextcache -v 1 -t -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions

Then try rebooting without -f

this won´t work for me caus i installed chameleon to a usb key....

and if i try to rebuild the cache on the key i get an error
think i don´t have the permissions

Open terminal and set permissions on the usb key like this:
sudo -s
/usr/sbin/vsdbutil -a /Volumes/(usbkey)

Then try building kextcache again with:

sudo kextcache -v 1 -t -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions


I tryed this but i think doesnt work.

i want the extension cache to be on the usb sticks root/extra folder. (like in this tuturial: http://aserebln.blogspot.com/)


Quote
sudo kextcache -v 1 -t -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions
and i think your terminal script will write the extensions into the mkext stored on OsX main Partition

My Hackintosh: • Intel Core2Quad Q6600 (g0) • PNY 8800gts 512 (g92) • Gigabyte Ga EP45-DS3R (Rev 1; BIOS v. f11e) • 2x2gb OCZ 1066MHz DDR3 • D-Link DWA 547 RangeBooster N

Drives: • HL-DT-STDVD-RAM GH22LS30  • SAMSUNG HD250HJ : Windows 7 Ultimate x64 • SAMSUNG HD161HJ :  Snow Leopard 10.6.3 • SAMSUNG HD103UJ : Backup

rzooff

  • Member
  • Posts: 59
Re: "boot ignore caches" for default ?
« Reply #9 on: October 04, 2009, 07:57:57 PM »
and i think your terminal script will write the extensions into the mkext stored on OsX main Partition
Yes, and it's the right place for it.

You can have two mkext files. One in Extra (made of Extra/Extensions) and the other in /S/L/Caches... etc (made of /S/L/E). Option -f rebuilds only the second mkext.
MacOS X 10.6.1 (Retail)  + Chameleon 2 | ASUS P5B-V | C2D E4600 | GF 8400GS | Asus WL-138g v2
MacOS X 10 10.5.8 (Retail) + Chameleon 2 | Toshiba L40-R17 |