Author Topic: USB boot shows either the USB partition or HD partitions, but not all  (Read 2647 times)

0 Members and 1 Guest are viewing this topic.


  • Entrant
  • Posts: 2
    • TaoZero
First - my deep appreciation for all the work you guys are putting into this, its an incredible project! Thanks for making such a useful tool.

I have Chameleon RC3 installed on my Hackintosh and works smoothly. This setup has 3 bootable partitions on a single MBR SATA HD (HFS+ OS X 10.5.2, HFS+ OS X backup, and FAT32 for XP).

I am trying to create a new multi-boot install on a USB stick that will allow me to boot into Chameleon with some bootable kits in case my HD dies or get corrupted (thinking GParted, Ubuntu live USB, Snow Leopard Install / Repair, etc).

However, when I boot from the USB I get the following:
* Chameleon boots nicely from the USB and presents the chosen theme (different from my HD one).
* While waiting for a key, I see the default boot partition on the USB. If I don't do anything, this partition boots as it should.
* If however I press a key to get all bootable partitions, I get my HD partitions but not the original USB partition. Selecting any of those boots into this partition normally.
* There seems to be no way to go back to the USB partition once Chameleon shows the HD list.

Here are the steps I followed to create the USB install (SuperTalent 4GB):
1. Using OSX Disk Utility (10.5.2), Format and partition an MBR drive with one HFS+ partition and whatever else (tried many options).
2. Manually install chameleon according to the USB install guide - boot0, boot1h, boot, Extras.
3. I placed a copy of the mach_kernel on the USB HFS+ partition just to prove that it works - the boot goes into this partition and indeed halts once it can't continue.

I tried re-creating the USB install from scratch several times with different variations (FAT32 partition first, GUID format, no kexts in Extra, etc) following various posts on the forum, but could not advance beyond this point.

Am I missing anything?
| OS X 10.5.2 | Antec 900 | GA-P35-DS3L | E6750 | Mushkin Silverline 2GB | GeForce 8600 GTS 256MB |


  • Entrant
  • Posts: 2
    • TaoZero
Some progress
« Reply #1 on: November 06, 2009, 09:51:14 AM »
It seems I am getting somewhere.

I have rebuilt the USB from scratch, this time in GUID.

Also, this time after reading some more threads I actually re-formatted the EFI partition using diskutil (as per the instructions)...

Both of those changes seem to help - now I can see the USB partitions side to side with the disk ones.

I am going to experiment some more, but this looks promising.
| OS X 10.5.2 | Antec 900 | GA-P35-DS3L | E6750 | Mushkin Silverline 2GB | GeForce 8600 GTS 256MB |