Chameleon => The Black Hole => Topic started by: kappachampion on June 09, 2011, 05:59:59 AM

Title: Video graphics only work when booting with F8
Post by: kappachampion on June 09, 2011, 05:59:59 AM
I have installed OSX on my laptop, an hp dv6233se, using leohazards 10.6.2 installer. I selected Chameleon RC4 (I'm assuming that is 2.0 RC4) from the installer. Now that it is installed, I can boot and the graphics do not function properly, however, if I hit F8 during boot the graphics work. I have tried disabling Quietboot and adding a timeout and neither make the graphics work (although, with the timeout I can see an expanding bar glyph - i.e. timeout countdown - within the static of the unusable graphics)

Can anyone provide insight as to what could possibly be different about booting with and without F8? Or any methods that I can test to try and get graphics working without hitting F8. I can access the machine and it functions properly if I boot using F8, so I can retrieve any files needed to troubleshoot.

Graphics Card: Nvidia go 6150
And I have tried adding many things to the com.apple.boot.plist to no avail, but it is currently unmodified.
Title: Re: Video graphics only work when booting with F8
Post by: Gringo Vermelho on June 09, 2011, 09:41:04 PM
We can only support installations done with retail DVDs + Chameleon installed manually or Chameleon boot CD built manually.

Not supported here:
Hackintosh distros/Hacked install DVDs
Third party boot CDs that use the Chameleon boot loader
Automated Chameleon installers
Chameleon installed and configured by someone else other than you (such as the author of a Hackintosh distro)
Really old versions of Chameleon that no-one on the moderation team can remember how to use.

Topic moved to the Black Hole.

As you have been told already, Geforce 6150/7150 are not supported by the OS X Nvidia drivers. But you should not see display corruption in the Chameleon GUI. Maybe you're setting an incompatible VESA boot resolution. Try a different one. Add to /Extra/com.apple.Boot.plist:

<string>Graphics Mode</string>
<key>WIDTHxHEIGHTxDEPTH</key> (e.g. 1024x768x32)
Try different resolutions, your display's native resolution might not be available as VESA mode!)

Try reading the Chameleon docs (a novel idea!) for other things you might try, boot graphics/instant menu setting etc:

If nothing helps, try upgrading to Chameleon 2.0 RC5, install manually.