Author Topic: audio skipping [ clipIfNecessary() ]  (Read 6100 times)

0 Members and 1 Guest are viewing this topic.

SP1950

  • Observer
  • Posts: 10
audio skipping [ clipIfNecessary() ]
« on: May 25, 2009, 12:14:35 PM »
The audio is not smooth when there is a higher cpu workload/hdd activity (i.e. skipping)
This is really annoying when listening to music. :-\

The computer is the aspire one with alc268 & intel atom, and using the VoodooPower.kext

Quote
IOAudioStream[0x2acbe00]::clipIfNecessary() - Error: attempting to clip to a position more than one buffer ahead of last clip position (1,1f3a)->(3,380).
IOAudioStream[0x2acbe00]::clipIfNecessary() - adjusting clipped position to (2,1f3a)

IOAudioStream[0x2acbe00]::clipIfNecessary() - Error: attempting to clip to a position more than one buffer ahead of last clip position (6bd,2b)->(6c2,c98).
IOAudioStream[0x2acbe00]::clipIfNecessary() - adjusting clipped position to (6c2,2b)

IOAudioStream[0x2acbe00]::clipIfNecessary() - Error: attempting to clip to a position more than one buffer ahead of last clip position (2982,82c)->(2985,1b88).
IOAudioStream[0x2acbe00]::clipIfNecessary() - adjusting clipped position to (2985,82c)

IOAudioStream[0x2acbe00]::clipIfNecessary() - Error: attempting to clip to a position more than one buffer ahead of last clip position (4393,7f8)->(4396,1b7a).
IOAudioStream[0x2acbe00]::clipIfNecessary() - adjusting clipped position to (4396,7f8)
IOHIDSystem::relativePointerEventGated: Capping VBL time to 20000000 (was 40253548)



maso

  • Entrant
  • Posts: 5
Re: audio skipping [ clipIfNecessary() ]
« Reply #1 on: May 26, 2009, 07:44:11 AM »
I had the same problem. Try the version without prefpane. Works like a charme for me.

SP1950

  • Observer
  • Posts: 10
Re: audio skipping [ clipIfNecessary() ]
« Reply #2 on: May 26, 2009, 12:22:17 PM »
I had the same problem. Try the version without prefpane. Works like a charme for me.
I am actually using the version w/o the prefpane, svn r8 to be exact.
I think this may be caused by the voodoopower.kext because i had kp/distorted audio with the old driver when running on battery only.

maso

  • Entrant
  • Posts: 5
Re: audio skipping [ clipIfNecessary() ]
« Reply #3 on: May 28, 2009, 08:20:47 PM »
I'm using the VoodooPowerMini. Don't know if this makes a difference.

pigeon

  • Entrant
  • Posts: 2
Re: audio skipping [ clipIfNecessary() ]
« Reply #4 on: September 26, 2009, 04:01:16 PM »
Hi.

I have the same problem with my ASUS N10Jc audio.

I get a lot of the clipIfNecessary messages and audio skips badly.

I notice one thing though, if I keep moving the mouse (either on the trackpad using voodooPS2 or an usb mouse), the audio becomes a lot smooth and almost skipless, even though I still get clipIfNescessary.


pigeon

  • Entrant
  • Posts: 2
Re: audio skipping [ clipIfNecessary() ]
« Reply #5 on: September 28, 2009, 04:45:26 AM »
As pointed out at http://code.google.com/p/voodoohda/issues/detail?id=30#c5 setting a lower audio format sampling rate gives less audio skipping.

Also if I remove the AppleIntelCPUPowerManagement kext, audio skipping completely goes away.