Author Topic: Blinking cursor after install.  (Read 15415 times)

0 Members and 1 Guest are viewing this topic.

BeSweeet

  • Entrant
  • Posts: 6
Blinking cursor after install.
« on: June 14, 2009, 12:22:07 AM »
Hi.

After installing Chameleon and reboot, I get a blinking cursor. Usually to boot into OS X, I used Vista's bootloader.

To boot into anything, I had to use Super Grub to reactivate my Windows partition. From the Windows bootloader, I can choose OS X (usually goes to the regular Darwin bootloader), it shows Chameleon! It's a really great piece of software.

Now, I want to use Chameleon as my bootloader for everything. If I set my OS X partition active from within Super Grub, I'll get the blinking cursor again.

So, is there a way to fix this blinking cursor nonsense?
OR! Is ther a way to install it on my Windows partition (or MBR or whatever)? That would be even better.

Thanks!
« Last Edit: August 17, 2009, 10:29:24 PM by rocksteady »

rocksteady

  • Global Moderator
  • Posts: 233
  • Root Down
Re: Blinking cursor after install.
« Reply #1 on: June 14, 2009, 10:23:07 PM »
Hello,

Did you try the Tips & Solutions already posted here?

Why double post to ask the same question?
Stop bitching, start coding or documenting or both..

P5Q-EM : Q6600 : 8GB RAM : 8800GT : SATA Drives

BeSweeet

  • Entrant
  • Posts: 6
Re: Blinking cursor after install.
« Reply #2 on: June 14, 2009, 10:54:46 PM »
What "Tips & Solutions"?

rocksteady

  • Global Moderator
  • Posts: 233
  • Root Down
Stop bitching, start coding or documenting or both..

P5Q-EM : Q6600 : 8GB RAM : 8800GT : SATA Drives

BeSweeet

  • Entrant
  • Posts: 6
Re: Blinking cursor after install.
« Reply #4 on: June 14, 2009, 11:15:04 PM »
None of that stuff helped.

I'm back to using Vista's bootmanager to boot chameleon. Don't really feel like messing with anything else.

rocksteady

  • Global Moderator
  • Posts: 233
  • Root Down
Re: Blinking cursor after install.
« Reply #5 on: June 14, 2009, 11:16:25 PM »
Sure, use whatever you like
Stop bitching, start coding or documenting or both..

P5Q-EM : Q6600 : 8GB RAM : 8800GT : SATA Drives

BeSweeet

  • Entrant
  • Posts: 6
Re: Blinking cursor after install.
« Reply #6 on: June 14, 2009, 11:16:56 PM »
I just wish there was a way to fix the blinking cursor issue when my OS X partition is active.

AniV

  • Observer
  • Posts: 18
Re: Blinking cursor after install.
« Reply #7 on: July 24, 2009, 01:01:24 PM »
Hi,

I'm showing you a way to fix the 'blinking cursor' problem after Chameleon2 installation on a dual boot windows7/ Vista + OsX system.

I've read a solution posted here: http://forum.voodooprojects.org/index.php/topic,311.msg1693.html#msg1693
but unfortunately that did not work for me, basically (i think) because repairing win7 puts back it's own
first stage boot loader, replacing CML2's 'boot0, preventing CML2 to be in charge.

So, if you are still having problems of this nature, continue reading.

The problem:
After win7 install, Chameleon2's installer (or the manual installation via fdisk for that matter) fails to write/ preserve the disk's signature to the MBR.

This results in:
   a - either not being able to boot into Win7, because fdisk (via manual CML2 install) may have zapped the disk's signature with zeros,
   b - or (via CML2's installer) failing to write CML2's  boot0 (due to 'resource busy' error) into disk's MBR,
   in a blinking cursor when OsX partition is active.

How do we go about it:
1 - Install windows7.
2 - Install Osx. Boot into OsX using some sort of Boot132 CD.
3 - Run CML2 installer. It says everything is fine, but it ain't.
     It has not written its 'boot0' into the disk's MBR.
3 - Copy the disk's signature win7 installer has written.
4 - Fix CML2's 'boot0' before writing it to the MBR.

Below is a small script that has fixed if for me.
Code: [Select]
#!/bin/bash
#
# Fix MBR after Windows7/Vista installation on a MBR disk!
#
# Why?: Chameleon2 'boot0' needs the disk signature,
# for Windows 7's bootmgr to work properly else it refuses to 'boot' :=)!
#
# When to Use?
# After failing Chameleon installation, with blinking cursor symptoms on reboot.
# AniV, July 24, 2009, for VoodooLabs.
#
# WARNING1:
# Make sure the disk's state is the one after Win7 Installation! else
# weird things will happen. We need to grab the MBR after Win7 install.
#
# NOTE: I'm assuming disk0 here! Adapt as required.
#
# 1 - Read partition MBR after Win7 installation!
dd if=/dev/rdisk0 of=disk0_win7mbr count=1
# 2 - Copy Win7 disk's signature to a file
dd if=disk0_win7mbr of=disk0_win7sig bs=1 skip=440 count=4
# 3 - Copy 'boot0' to 'boot0_win7sig' (boot0 with disk0 win7's signature)
cp boot0 boot0_win7sig
# 4 - Merge 'disk0_win7sig' onto 'boot0_win7sig'. Note 'boot0' length=512!
dd if=disk0_win7sig of=boot0_win7sig bs=1 seek=440 count=4 conv=notrunc
#
# You can inspect the boot0 you're about to write! Use 0xED hex editor.
# 5 - Write Chameleon2 Partitionloader code into MBR
# this will install 'boot0 + win7sig' and restore disk's signature!
#
fdisk -f boot0_win7sig -u -y /dev/rdisk0
#
# Make sure your OsX partition is active and reboot.
#

Please be careful, this may render your system unbootbale. Make sure you understand it first.

Hope it can help someone. Cheers.


"Life is what happens to you while you're busy making other plans". .

Kabyl

  • VoodooLabs
  • Posts: 158
Re: Blinking cursor after install.
« Reply #8 on: July 24, 2009, 01:19:48 PM »
Below is a small script that has fixed if for me.

All this wouldn't happen if people were using the modified fdisk which keeps the Windows disk signature.

AniV

  • Observer
  • Posts: 18
Re: Blinking cursor after install.
« Reply #9 on: July 24, 2009, 02:55:46 PM »
Quote
All this wouldn't happen if people were using the modified fdisk which keeps the Windows disk signature.
Come on Kabyl,

Where's the beautifully modified 'fdisk' ? People simply don't know where to find it.
I, for one, have spent quite some time (apparently wasted?) on this.
More docs, when you can, please. Cheers.
"Life is what happens to you while you're busy making other plans". .

Kabyl

  • VoodooLabs
  • Posts: 158
Re: Blinking cursor after install.
« Reply #10 on: July 24, 2009, 07:28:58 PM »
Quote
All this wouldn't happen if people were using the modified fdisk which keeps the Windows disk signature.
Come on Kabyl,

Where's the beautifully modified 'fdisk' ? People simply don't know where to find it.
I, for one, have spent quite some time (apparently wasted?) on this.
More docs, when you can, please. Cheers.

Well how would I know about that? no one asked for it :)
It's included in the bin. tarball.




^ [Added visual evidence, w/o adding another post]
« Last Edit: July 25, 2009, 04:06:49 PM by rocksteady »

AniV

  • Observer
  • Posts: 18
Re: Blinking cursor after install.
« Reply #11 on: July 26, 2009, 01:25:13 PM »
Quote
All this wouldn't happen if people were using the modified fdisk which keeps the Windows disk signature.
Come on Kabyl,
Where's the beautifully modified 'fdisk' ? People simply don't know where to find it.
I, for one, have spent quite some time (apparently wasted?) on this.
More docs, when you can, please. Cheers.
Well how would I know about that? no one asked for it :)
It's included in the bin. tarball.

^ [Added visual evidence, w/o adding another post]
Thanks for that, now it's clearer.

Today, I've have found some more info on 'fdisk', over on the Chameleon 1.0.11 forum of one year ago...
over here:
http://chameleon.osx86.hu/articles/chameleon-1011-with-jmicron-ide-dvd-sse2-amd-k10-phenom-support#c000112
and
http://chameleon.osx86.hu/articles/chameleon-1011-with-jmicron-ide-dvd-sse2-amd-k10-phenom-support#c000267

BTW the source of the 'modified fdisk' can be found inside the chameleon 1.0.11 src tar ball.
I think, it's about time to update the 'manual install method' referring to this very important issue.

PS1: I know the new RC2 has just been released but, I'm afraid the installer still has not been fixed.

Let's all contribute to improve this nice bootloader. Cheers.


Moderator Edit: Thanks for your efforts AniV, I marked the thread as solved. Your solution will probably make it to the (forthcoming) Tips thread.
« Last Edit: August 17, 2009, 10:29:58 PM by rocksteady »
"Life is what happens to you while you're busy making other plans". .

BeSweeet

  • Entrant
  • Posts: 6
Re: [SOLVED] Blinking cursor after install.
« Reply #12 on: August 17, 2009, 05:07:21 PM »
The problem isn't solved, I just used  a different bootloader other than the one I was having problems with.

Installed RC2 today. Same shit. Back to Window's 7's bootloader.