overdue-scratch

Author Topic: External HD Causing Chameleon Errors & 1 Min delay to appear.  (Read 11199 times)

0 Members and 1 Guest are viewing this topic.

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #15 on: January 16, 2011, 09:28:50 PM »
For you it works fine. So the problem doesn't exist?
I did not say or even imply anything like that.

Knowing that it works on my configuration and not on yours is useful information don't you think?

10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

Slice

  • VoodooLabs
  • Posts: 52
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #16 on: January 17, 2011, 09:32:45 AM »
Rather no then yes.
I am searching any info/confirmation of the bug. It looks like no one ever encountered it or just ignores the problem.

I saw the problem with many other versions of Chameleon, even with 1.0.11.
Previous one with NawcomCD. What is Chameleon there?
When I boot with it  I see GUI with a list of drives where I can choose a partition to load. No! It's impossible! Only CD.

The task is follow: during installation I have broken boot0 or boot1. To restore installation I want to boot from CD and then load good system from HDD. I have many bad experiences.
Good experience I have with bootable USB stick. It works on Dell notebook.
Some problem with it presents while booting Samsung notebook. USB bus is not responded during 1-3 minutes. But booting the same chameleon from HDD I see USB is fine. Why? Just different gBIOSdev.

And I still can't understand how to do bvChain to be correct while booting from CD.

Xeikon

  • Observer
  • Posts: 12
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #17 on: January 17, 2011, 02:33:16 PM »
You should definitely install the latest version of Chameleon.
AsereBLN is no longer in development (your version is almost a year old) and the author has disappeared from the scene. Chameleon 2.0 RC5 can do everything that AsereBLN 1.1.9 could do, and much more.

If your drive is GUID partitioned you can use my guide and files from here:
http://forum.voodooprojects.org/index.php/topic,649.0.html

Note, you don't have to install Chameleon to your EFI partition, you can install it to your system partition as well if you want to, just change the diskxsy commands where necessary. Obviously you should install it to the same place where your present bootloader is installed to so that it will get completely replaced. It is your job to know where that is.
 
zip and attach your com.apple.Boot.plist, it probably has some AsereBLN specific settings that will have to be changed to work with Chameleon 2.0 RC5.

Slice:

I have two hard drives, one with Windows 7 and one with Snow Leopard, I can boot both with my Chameleon boot CD, no crashes or kernel panics. If I plug in an USB flash drive it will list that as well. So for me it works fine.

May be I am the BUG !! and all this is just happening because I have an old version of Chameleon. Please let me take a good look at you guide and install the latest version of Chameleon. I am not fast with those situations. I would try to make a back up first. Thank you so much for your help.

Xeikon

r007

  • Observer
  • Posts: 21
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #18 on: January 17, 2011, 07:58:24 PM »
If you have everything working it is usually just a matter of replacing the "boot" file on your boot partitions root directory ("/"). YMMV.

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #19 on: January 17, 2011, 11:37:42 PM »
Replacing just /boot will only make matters worse. Xeikon is using a version of Chameleon that is over a year old, he must do a full installation.
« Last Edit: January 18, 2011, 12:08:23 AM by Gringo Vermelho »
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

Xeikon

  • Observer
  • Posts: 12
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #20 on: January 17, 2011, 11:51:11 PM »
@Gribgo Bermelho: I took a look at your guide and sincerely found it a little difficult for my knowledge of Chameleon. Please, note that, your guide looks very nice and very detailed. Is just that my knowledge is not up to it. Do I have to reinstall all the OS again ?? Or... would you please tell what part of your guide applies to my case. I don´t know why I have the felling that not the complete guide applies to upgrading Chameleon.

Thank you very much,

Xeikon

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #21 on: January 18, 2011, 12:11:36 AM »
No, you don't have to reinstall everything. Just Chameleon.

Please be more specific, I can't guess what you need to know.
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

Xeikon

  • Observer
  • Posts: 12
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #22 on: January 18, 2011, 12:26:01 AM »
Hello Gringo: I think I will have to start your guide at the point where says:

"Now you can copy the extra, themes and extensions folders, your DSDT.aml, your com.apple.Boot.plist, your smbios.plist and of course your extensions to it.  ........."

Since I already have a running, active, EFI HD. Please correct me if I am wrong.

PD: Off-Topic: Where are you from ???

Thanks

Xeikon

Zane

  • Member
  • Posts: 81
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #23 on: January 18, 2011, 09:59:57 AM »
You might wanna use the Guide from http://www.insanelymac.com/forum/index.php?showtopic=164809. However i just recommend changing the first command to ./fdisk440 -f boot0 -u -y /dev/rdisk0 if you have a dual boot with windows. However you would have to cd to the i386 folder of the chameleon binaries.

@Gringo Sorry for hijacking and providing another guide.

-Zane
http://bit.ly/osx86log Lenovo Y550P OSx86 Log
http://bit.ly/envyosx64log HP Envy 15 1150nr OSx64 log

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #24 on: January 18, 2011, 05:53:19 PM »
That's okay Zane, the more the merrier, but note that external links are kind of against the rules on this forum. That's why I wrote the guide here in the first place. Or rather copied and pasted and changed some words.  :)

Anyway, no matter which guide he chooses to follow, he still have to know first whether his drive is GUID or MBR and to which partition his present version of Chameleon is installed so that he can overwrite it with the new one. None of these guides can tell him that.

Xeicon: I am originally from northern Europe but I live in Brazil for 5 years now.
I can't see into your computer - that might be where you have to start from, but I can't confirm that for you from where I am!
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

Xeikon

  • Observer
  • Posts: 12
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #25 on: January 18, 2011, 09:00:08 PM »
Well, the list of HDs is like this... as you see the HD containing the MAC OSX is GUID

bash-3.2# diskutil list

/dev/disk0
   #: TYPE NAME                               SIZE         IDENTIFIER
   0: GUID_partition_scheme          *250.1 GB   disk0
   1: EFI                                           209.7 MB   disk0s1
   2: Apple_HFS MAC                        151.8 GB   disk0s2
   3: Microsoft Basic Data MACBOX      98.0 GB    disk0s3

/dev/disk1
   #: TYPE NAME                           SIZE            IDENTIFIER
   0: FDisk_partition_scheme         *500.1 GB   disk1
   1: Windows_NTFS Untitled           107.4 GB   disk1s1
   2: Windows_FAT_32 BOX 64        197.0 GB   disk1s3
   3: Windows_NTFS CAJA 2             195.7 GB   disk1s5

/dev/disk2
   #: TYPE NAME                             SIZE       IDENTIFIER
   0:  FDisk_partition_scheme         *1.0 TB     disk2
   1:  Windows_NTFS Iomega HDD    1.0 TB     disk2s1

@All people who is helping me: The two guides, kindly refereed to me, say that I should make the disk bootable and make the specific partition active. In my case, all that, is already happening. I wonder why do I have to make all the disk & partition bootable & active. There is a way to just intall Chameleon and the copy in it my personalized plist and files? ?????

Thank you all !!! very much

Xeikon

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #26 on: January 19, 2011, 01:38:16 AM »
Right. No, if you already have Chameleon installed to the EFI partition on your disk0, just follow this to the letter:

Install boot0 to the MBR:
./fdisk -f boot0 -u -y /dev/rdisk0

Install boot1h to the bootsector of the EFI partition:
dd if=boot1h of=/dev/rdisk0s1

Then, copy the file ‘boot’ to it:
cp boot /Volumes/EFI

That's all as far as upgrading goes.
The rest is configuration via plists, other files and such, specific to your system.

However, I don't know if Chameleon is installed to your EFI partition or to your system partition.
It is your job to know that.
« Last Edit: January 19, 2011, 01:44:57 AM by Gringo Vermelho »
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131

Zane

  • Member
  • Posts: 81
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #27 on: January 19, 2011, 09:49:09 AM »
That's okay Zane, the more the merrier, but note that external links are kind of against the rules on this forum. That's why I wrote the guide here in the first place. Or rather copied and pasted and changed some words.  :)

Anyway, no matter which guide he chooses to follow, he still have to know first whether his drive is GUID or MBR and to which partition his present version of Chameleon is installed so that he can overwrite it with the new one. None of these guides can tell him that.

Xeicon: I am originally from northern Europe but I live in Brazil for 5 years now.
I can't see into your computer - that might be where you have to start from, but I can't confirm that for you from where I am!

Oops. I shall refrain from posting external links then. I just sometimes find that that guide is easier to "comprehend" for beginners.
http://bit.ly/osx86log Lenovo Y550P OSx86 Log
http://bit.ly/envyosx64log HP Envy 15 1150nr OSx64 log

Xeikon

  • Observer
  • Posts: 12
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #28 on: January 19, 2011, 02:14:56 PM »
Hello Gringo: Thanks for the steps and guide. Looking at your guide, I see that you are activating the disks to boot correctly. What I really don´t know is how to to look into the  EFI partition to see if chameleon is there as  a boot system. I can see into the System partition /extra folder and there are the configuration files. But I don´t know how to check into the EFI (200 MB or so partition). I really understood, that you said "it´s your job to know that", but I really don´t know how to do it.

Thanks for your help.

Xeikon

Gringo Vermelho

  • Forum Moderator
  • Posts: 611
  • The gray monster energy hat
Re: External HD Causing Chameleon Errors & 1 Min delay to appear.
« Reply #29 on: January 19, 2011, 05:23:41 PM »
That's simple, just try mounting it. Commands are in the guide. If you can't mount it then it hasn't been initialized and there's nothing on it. Another way to quickly check where Chameleon is installed is to look for the file "boot". If it's at the root of your system drive, then that's where Chameleon is installed. Note that this might be a hidden file and you will not be able to see it in the Finder, unless you enable hidden files:

defaults write com.apple.finder AppleShowAllFiles TRUE (run the command again but with FALSE to disable view hidden files)

However, since you have an Extra folder at root I think it's safe to assume that Chameleon is installed to your system partition.

Zane: Feel free to rewrite the installation guide you linked to and post it here in the General forum....make it even more no0b friendly if you feel like it. Don't forget to credit the original author. You can link to the files in my guide (i386 folder and default theme), I try to keep them updated when I can.

« Last Edit: January 19, 2011, 05:37:01 PM by Gringo Vermelho »
10.9.5 - ASUS P8Z77-V Pro - i5 3570K - GTX 660 - Chameleon 2.3 svn-r2xxx
How to...
Install Chameleon: http://forum.voodooprojects.org/index.php/topic,649
Make your own Chameleon boot CD: http://forum.voodooprojects.org/index.php/topic,484.msg2131.html#msg2131