Author Topic: Chameleon 2.0-RC2 Dual boot problem  (Read 3322 times)

0 Members and 1 Guest are viewing this topic.


  • Entrant
  • Posts: 4
Chameleon 2.0-RC2 Dual boot problem
« on: August 10, 2009, 11:14:29 AM »
 I "think" this is a windows problem but effects Chameleon 2.0-RC2.
Have XP on second partition (236Gb). Created a 30 Gb HFS and did a kalyway 10.5.2 install (so i can make a boot CD to boot retail). (partition 30Gb, 236Gb +unallocated)
Chose MBR & vanilla install.
Windows would boot via the darwin loader (i have chain0 in the windows root).
Leopard would load using the darwin loader . If i set the windows boot active would boot straight into windows. All OK  :)
All good.  :)

Installed Chameleon 2.0-RC2 and could boot into leopard but not into XP. Tried using windows fixboot & fixmbr to fix it. No combination could let me get to windows. (Would break darwin bootloader) Could not get into using generic 132 boot disc.

I deleted the kalyway install & could boot into windows without doing anything else.

Repeated the whole kalyway install but added a 100Mb FAT partition as well. (partitions now 30Gb , 100Mb, 236Gb +unallocated)

Now when i installed Chameleon 2.0-RC2 all worked as should.

I suspect windows does not handle the EFI partition. I seem to recall microsoft admitting that windows always assume the second partition on a disk to be the EFI partition.

I note the kalyway install has marked the 100Mb partition as LBA. (I think unix does this as default for EFI partition?)

Now working on the boot  CD  for the retail install  :) (and having trouble  :( )

System is a Gigabyte EP31-DS3L 4G mem 320Gb hd.